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InRoads Master Workflow

Getting Started
 If the project folder has not already been created, create the folder as u:/rd/prj/COUNPCN# 

using Windows Explorer.  
 Create a new Microstation 3D graphics file, saving it as ePCN#.dgn in the project folder. 

Recommend using applicable seed file NorthZoneSPC.dgn or SouthZoneSPC.dgn, which 
contains useful reference files such as MRM. Close file

 Click and drag Microstation to the bottom of your left screen bar <Left click> on Microstation  
and pin [to this list (right side)] your ePCN#.dgn. Open file  F1 key to start InRoads

 Attach the topography file as a reference file from the u:\regionXX\prj\COUNPCN# folder.
 Execute MicroStation’s File > Save Settings command.
 Toggle on Pencil/Pen and the Delete Ink checked
 Urban Projects    Select  File<Project Options> Urban preference  Load <Close> <Close>
For each specific project the preference for urban, suburban or rural will need to be set in order 
for the design to scale properly.   

Open InRoads Files
See Appendix A for instructions on creating an InRoads Project file.  An InRoads Project file allows the 
user to simultaneously open selected InRoads design files.  This file can be created at any time.

Original Ground Surface

Open the original ground DTM from the REGION folder 
(u:\regionXX\prj\COUNPCN#\PCN#org.dtm).

Geometry Project

 File > New.
 Under the Geometry tab select Geometry Project as the geometry type and enter ePCN# as 

the project name.  Add pertinent information in the Description field.
 Save the design geometry to the corresponding project folder as (ePCN#).  The save process 

will default to “Geometry Projects (*.alg)”.

Open Design File
xxxx.dgn

Open InRoads
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Create and Edit Horizontal Alignments
Open the geometry project (ePCN#.alg) from the project folder.

 Create Horizontal Alignment File > New.
 Under the Geometry tab select Horizontal Alignment as the Geometry Type, enter mainline 

as the alignment Name, select mainline for the Style and the Curve Definition should be set 
to Arc.  Add pertinent information in the description window. Note, all alignments should have 
the style set to mainline. Also, the default style is the same as the mainline style. 

See CADD procedures Section A regarding proper naming convention for non-mainline alignments.

Create PI’s – There are three separate and independent methods for creating horizontal alignments:

 Geometry > Horizontal Curve Set > Add PI – Identify points for PI’s using graphics and/or 
key-ins.  (Example key-ins: ne = northing & easting coordinates; di = distance & direction).  
Note:  This is the typical method that is used.

 Geometry > Horizontal Elements
 Geometry > Utilities > Create/Edit Alignment by COGO Points – The COGO point names 

must be numeric.
 The PI’s can be displayed by using Geometry > View Geometry > Horizontal Annotation, 

and toggling on Display Points / Off-Alignment.

Computations are planer even if the horizontal alignment includes several different elevations.

Add Horizontal Curves (Horizontal Curve Set method)

 Geometry > Horizontal Curve Set >Define Curve
 Move from PI to PI by selecting Next or Previous at the bottom of the dialog box until the 

desired curve set is highlighted.  Fill in the Horizontal Curve portion of the dialog box.  For 
simple curves, the Curve Set Type = SCS.  Enter desired curve radius (Radius 1).  The 
Leading & Trailing Radii for simple curves = 0.

To eliminate a short tangent between Horizontal Curves (two different options):

1. Floating Curve

 Turn off Accusnap
 Lay out Horizontal PI’s as described above.
 Geometry > Horizontal Element > Add Floating Curve
 Set Mode to Point & Direction.  Be sure the Point checkbox is toggled on.
 Create the 1st Horizontal Curve.

 Select the Point target and snap to the PRC (midpoint of the ahead tangent is a good 
place to snap to, but any point along that tangent will work).

 Select the Direction target and identify the direction of the ahead tangent of the 1st 
curve.

 Select <Apply> and select the back tangent (somewhere near the PI) of the 1st curve.  
Data point to accept.

 Create the 2nd Horizontal Curve.
Select the ahead tangent (somewhere near the PI) of the 2nd curve.  Data point to 
accept.

 Delete the middle tangent.
 Geometry > Horizontal Element > Delete Element
 Set Inclusion Mode to Selected Element Only.
 Select <Apply> and select the middle tangent.  Data point to accept.

http://www.sddot.com/pe/roaddesign/docs/Procedures/CADD-General.pdf
http://www.sddot.com/pe/roaddesign/docs/Procedures/CADD-General.pdf
http://www.sddot.com/pe/roaddesign/docs/Procedures/CADD-General.pdf


5

Note:  The Middle Tangent Direction remains the same in this option.  The horizontal curve radii are 
based upon the location of the PRC that is selected.

2. Free Curve

 Turn off Accusnap
 Lay out Horizontal PI’s as described above.
 Select desired radius for 1st Horizontal Curve. (Geometry > Horizontal Curve Set >Define 

Curve & Apply)
 Geometry > Horizontal Element > Add Free Curve
 Enter desired radius for 2nd Horizontal Curve.

 NOTE: If you need your 2nd Horizontal Curve to curve to the left (CCW), you need to 
enter the desired radius with a negative (-) symbol in front of the radius value.

 Make sure the box to Delete Existing Elements Between First and Second is checked
 Click Apply
 You will be prompted to Identify 1st Element – Select the 1st Horizontal Curve
 You will then be prompted to Identify 2nd Element – Select the Ahead Tangent of the 2nd 

Horizontal Curve
 Data Point to Accept

SAVE !!  When the information is worth saving – Save It.

Review the Horizontal Alignment

 Geometry > Review Horizontal,

Annotating the Horizontal Alignment

 To annotate the Bearings, PC’s, PT’s and ends of the alignment:
 Geometry > View Geometry > Horizontal Annotation
 Set Apply Style to Assigned (as set when alignment was created) or Active (Style set 

will override the Style assigned to the alignment).
 Select the appropriate Preference for the type of project being designed.
 Enter the alignment to be annotated.  Toggle on Display Points / On-Alignment and 

<Apply>.
 Stationing:

 Geometry > View Geometry > Stationing
 Select the appropriate Preference for the type of project being designed.
 Under the General Tab, select the Horizontal Alignment to be stationed and <Apply>.

 PI curve data:
 Geometry > View Geometry > Curve Set Annotation
 Select the appropriate Preference for the type of project being designed.
 Under the General Tab, Select the Horizontal Alignment to be annotated and 

<Apply>.

In general, for reconstruction projects the beginning station of horizontal alignments should be 0+00.  The 
work should begin at 10+00 for all scales.  This allows for work to begin previous to 10+00, if needed, 
without changing the stationing of the design data and notes.  

Setting the beginning station to the necessary “begin station” can be accomplished by the following:

 Geometry > Horizontal Curve Set > Stationing
 Select the Horizontal Alignment
 Enter the desired starting station in the Starting Station and <Apply>.
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Horizontal & Vertical Alignment Coordination

 Geometry > Horizontal Curve Set > Stationing
 Note – Prior to performing any of the following, save a copy of your current information.
 Within this dialog box there are choices under Vertical and Superelevation Alignments.
 Do Not Update – If you add 1,000’ to the Horizontal Alignment Stationing, the Vertical 

Alignment Stationing will not change.
 Synchronize Starting Stations – If you add 1,000’ to the Horizontal Alignment Stationing such 

that the Begin station is 110+00, the Begin Station of the Vertical Alignment will be changed 
to match the Horizontal at 110+00 regardless of what it was previously.

 Maintain Station Difference – If you add 1,000’ to the Horizontal Alignment Stationing, 1,000’ 
will be added to the Vertical Alignment Stationing.  Typically, this is what we would utilize.

Horizontal Station Equations

 Geometry > Horizontal Curve Set > Stationing
 Select “New” at the bottom of the dialog box.
 Enter the Back and Ahead Stations for the equation and enter <Apply>.
 For “Overlap” equations, the Ahead Station will require an “a” in front of the station.  For 

subsequent “Overlap” equations, you will need to continue with “b”, etc.

Adding Horizontal Event Points (Pipe, Entrance, and other desired special cross sections)

 Geometry > Horizontal Curve Set > Events
 Define by: Single Station
 Add As: Station and Offset
 Locate By: Enter the desired Station (Offset = 0) and <Apply>.
 Event point stations can be edited within this dialog box.

Note – If the horizontal alignment stationing is changed, horizontal event points do not update.  They 
remain at the Station that they were set at.  They can be edited individually as noted above.

It is very important that all the points defining the Horizontal Alignment be at the same elevation 
(1500.00).  If all the same elevations are not used, the plan sheets may be cut incorrectly.  Review the 
horizontal alignment - Geometry > Review Geometry Points > Report.

If the alignment points are on different elevations, they can all be moved to one elevation by choosing “All 
Points” under “Mode”, typing the desired elevation and <Apply>.

Horizontal Alignment Reports.  You can create reports to review your alignment.

 Tools > XML Reports > Geometry
 Select Horizontal Alignment and <Apply> .
 Numerous .xml Report options are generated.  Some will be partially or completely blank due 

to a lack of input data.  Select desired .xml Report and Review.
 To save a hard copy of any report, highlight desired .xml Report.  File > Save As >  Select 

Word Document format (.doc) and save to appropriate directory.
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Alternatively, you can create a report by selecting Geometry > Review Horizontal >  This report can be 
saved to a hard copy similar to that described above.  File Save As >  Select Notepad format (.txt) and 
save to appropriate directory.

Extract Profiles
The purpose of this process is to create a profile for displaying the existing ground profile, and from which 
the new grade line may be established.

 Open the geometry project file and set active the appropriate horizontal alignment.
 Open and set active the original ground dtm (PCN#org.dtm) from the respective region 

project folder.

Before creating the existing ground profile, verify the existing ground elevation limits (Surface > Surface 
Properties) and adjust the profile limits accordingly to allow for the display of design vertical PI’s.

 Set Station Lock to ON.
 Evaluation > Profile > Create Profile
 Select the appropriate Preference for the type of project being designed (appr_pipe, Rural, 

Storm, Suburban, Urban).
 Under the General leaf/Surfaces toggle on the PCN#org surface.
 Under the Source leaf/Alignment select the active horizontal alignment (this will draw the 

original ground along the active horizontal alignment). 
 Under the Controls leaf enter the minimum and maximum elevation limits as explained 

above.  Likewise, Station Start and Stop limits should be entered at this time as necessary.
 <Apply> and then place a Data point to locate the lower left-hand corner of the profile.  The 

profile grid will be generated with the execution of the Create Profile command.

Create and Edit Vertical Alignments
Open the geometry project (ePCN#.alg) from the project folder.

 Set the Horizontal Alignment to mainline.
 File > New.
 Under the Geometry tab select Vertical Alignment as the geometry type and enter mainline 

as the alignment name.  Add pertinent information in the description window.
 Graphically lay out vertical alignment PI’s
 Geometry > Vertical Curve Set > Add PI
 PI’s can also be added by keying in station and elevation using se=  (station and elevation)

View Alignment

Geometry > View Geometry > Active Vertical

Add vertical curves

 Geometry > Vertical Curve Set > Define Curve
 Identify the vertical PI by clicking <Next> until the desired PI is highlighted.
 Enter vertical curve length in Length field
 <Apply >

SAVE !!  When the information is worth saving – Save It.
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Before exporting/importing horizontal and vertical alignments, change all curve lengths to 0 feet.  This will 
allow the alignment to be defined with PI’s rather than components.

Vertical Alignment Reports

 Tools > XML Reports > Geometry
 Create the vertical alignment report following the same procedure as outlined above for 

horizontal alignments, substituting vertical for horizontal.

There are different methods to get the templates and roadway designed for your specific project.

Copy Templates
Create a new Template Library

 Modeler>Create Template
 In the Create Template box, select File > New Template Library
 In the Save As box, key in (PCN#.itl) 
 Select Save

Copy Standard Typicals
 In the Create template box, select Tools>Template Library Organizer
 In the Organizer box’s Available In section, select the Browse (…) button and browse to 

U:\rd\Bentley\V8i\Inroads\data\English\SDDOT.itl then select Open
 Expand the directory tree on the right side
 Drag and drop folders or individual templates as desired from the right side (…SDDOT.itl) to 

the left side (…PCN#.itl)copy from
 Select OK
 When prompted to save data, select Yes

The template will need to be adjusted to match the design summary.  Make the necessary modifications 
to lane, shoulder, subgrade widths and undercut depths, etc.  Refer to Editing Templates.

Editing Templates
Note: Templates can be modified in both the .itl and the .ird files. The preferred method is to modify them 
in the .itl file. If templates are modified in the .ird file they cannot be synchronized with the .itl anymore 
without losing the edits made to the .ird.

 <Double Click> u:\rd\prj\COUNPCN#\PCN#.itl in the Create Template box, the tree view, 
select desired Roadway Templates or Typical Sections. 

You can either select typical sections which already have the end conditions attached or select 
roadway templates and then add the desired end conditions.

 Notice the selected template is displayed in the view on the right
 To add end conditions to a roadway template in the Create Template box, the tree view, 

Template Library <Click> desired end condition drag (but before releasing it) right-mouse 
click to access the mirror option, then place on the desired  roadway template. 

 <Double Click> on each end condition    Component Properties   Target Type Surface
Surface      PCN#org 

You may choose to delete end conditions, roadway templates or typical sections that do not pertain to 
your project.  You may also choose to copy and paste the roadway templates with end conditions into the 
typical sections folder.  There is no right way or wrong way to achieve the roadway typical section.   
The software has options to edit templates.  Refer below
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Option 1
 Create Template box, data your roadway typical section and in the view on the right displays  

the components, (Horizontal, Vertical and Slope) parametric constraints,  etc. 
 Display Box <Constraints button on> and Display Point Names checked to help make the 

necessary changes.
 Increase your view and move cursor on the drawing in the cross section view and a box will 

indicate if it is a point or a component with other information. To edit lengths of constraints to 
match your design summary <double click> on red plus signs or move cursor to the red plus 
sign and <right click> and <click>edit point then change the desired parameters in the Point 
Properties 

 Select previous or next to move within the template in the Point Properties 
 You may need to delete, move or add constraints for your specific project.  
 To add a finished surface in the urban design <right click> on your starting point add new 

component, constrained, move cursor in direction up from subgrade connect the area 
component with points <right click> and finish. Design Constraints from your subgrade line 
<double click>(new point) change horizontal value to 0.00 under constraint 1 and vertical 
value to surface thickness under constraint 2. Label as Lane, Surface Feature Style as 
Finish, Member of Finish. Complete constraints for all new points within the finish component

 Verify Template Origin is correct in relation to your vertical alignment
 For Surfaces Finished and Undercut In Component Properties check mark Exclude from 

Triangulation

Verify all point properties are designed correctly for your project with respect to parent names, slopes, 
values, constraints, components, etc. 

A mainline template may include the standard mainline components, finish, subgrade and undercut.  See 
CADD procedures Section A regarding proper naming convention for non-mainline Layers.

 When the creation of the Roadway Typical Section is complete, save the Template 
Library, File save as PCN#.itl.

 Close  
Option 2

 Modeler > Roadway Designer
 Tools > Parametric Constraints  Constraint Label drop down box for lane, left shoulder, 

right shoulder, sidewalk, subgrade and undercut.  For each label activate the start and stop 
station with the start and stop value.  <Add>  [example: the constraint label Lane from station 
to station is 12’ then all lanes left and right will be shown as 12’).   

 Close
 Each point in the template is named with a Surface Feature Style, Constraints 1 & 2 with 

Parent and values. Point Properties for Cut and Fill Slopes have additional End Condition 
Properties.  (Example:  the segment to the right of centerline on the rural template is 
“R_Lane” - See Example:  rural that follows).  These Point Properties are to be left as they 
are unless it is deemed necessary to change them. 

http://www.sddot.com/pe/roaddesign/docs/Procedures/CADD-General.pdf
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 Point Property names should remain consistent for transitioning from one template to 
another.

 To edit lengths of components to match your design summary use Point Properties for 
defining the roadway section beyond the subgrade limits.  This can define standard cut and 
fill sections as well as urban cut and fill sections.  It is flexible in that any number of situations 
can be coded into a particular Template to define special criteria such as a special ditch or 
flatter than standard fill slope.

Create a Roadway
Create a Roadway as follows: 

 Modeler > Roadway Designer
 Corridor > Corridor Management  
 Manage Corridors Name mainline, Surface Symbology mainline, Type alignment, Horizontal 

alignment mainline, Vertical Alignment mainline   Limits Toggle Station start and stop  if 
desired < Add> A project must have one corridor to create a valid design from which a 
surface can be created. Notice you can add, copy, change or delete corridors from your 
design at any time.<Close>

 Save the Roadway Designer to the corresponding project folder as (PCN#).  The file save as 
process will default to “ Roadway Design (*.ird)”.

 Notice that you can also directly open a PCN#.ird file using File>Open in Roadway Designer.
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 The top-left window is the plan view and displays the alignment (mainline) of the active 
corridor in light blue.  The active surface perimeter is shown as white  (Lock Active Surface to 
PCN#org), the current station location is shown as the yellow line.  The bottom–left window is 
the profile view. The large top-right window is the cross-section view. 

Dropping Templates in the Corridor

 Corridor > Template Drops 
 Template drops comprise a series of points and components that represent breakline 

features that are processed using the Roadway Designer command. A component is a set of 
points that define an open or closed shape.  Each component, whether open or closed, can 
represent a different material or area of interest.  Components are named and have an 
assigned style. There are 5 types of components created in InRoads: Simple, Constrained, 
Unconstrained, Null point, and End Condition. For more specific details on components, see 
the Create Template Overview help topic. 

 Library Templates box <Browse>button to find u:\rd\prj\COUNPCN#\PCN#.itl. Select Corridor 
mainline, In the Station field, enter station where the desired template will begin.  In the 
Interval field, input the interval by which InRoads will “drop” a template for modeling (typically 
50 feet for rural and/or urban projects).

 <Double Click> u:\rd\prj\COUNPCN#\PCN#.itl in the Library Templates box, the tree view, 
select desired Roadway Templates or Typical Sections  then <Add>.  

 Notice the selected template is displayed in the view on the right, and is added to the Current 
Template Drops list at the bottom of the dialog box.

If a template needs to be modified at a later time you can do this by editing the template in the 
template library (.itl). Once the template has been modified in the template library it will need to be 
synchronized in the template drops dialog box. The templates used in the template drops will appear 
red indicating that the .ird file does not match what is in the template library. Once this is 
synchronized, the template drop will appear black again. It is preferred that the templates in the 
template drops dialog box be synchronized with the template library as much as possible. Any edits 
done to the template drops themselves will be lost once the template drops are synchronized again.

Add a new template for each change in shrink value (Enter appropriate shrink value for each undercut 
based on specified station ranges. In order to have different shrinkage values for the undercut, the 
undercut component name such as Undercut 30%, Undercut 40% and symbology such as UndercutA, 
UndercutB will need to be changed for each shrink value.)

Complete your Current Template Drops with each station, interval and template to match your design 
summary.  Basically like the old Roadway Modeler run within the Roadway Library.

Once you have closed the template drops box. In the plan view, notice the visual cues (Brown Lines) 
that show the location of the each new template drop.  In cross section the templates are displayed.

When the creation of the Roadway is complete, save the Roadway Corridor and File save as 
PCN#.ird.
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Special Ditches
Special Ditches are ditches whose grade line does not parallel the roadway grade line.  When special 
ditches are required, additional vertical alignments need to be created under the appropriate horizontal 
alignment.   InRoads<Tools> Application add-ins  <Click> Horizontal and Vertical Elements Add-In

 Create the vertical alignments special ditch left and/or special ditch right using the steps 
outlined above for creating vertical alignments.

 Set the newly created special ditch alignment active.
 Geometry > Vertical Element > Add Fixed Line…
 Set Mode to By Two Points.
 Toggle on each of the two Station / Elevation sets.
 Fill in the desired station and elevation for each segment, verifying that the stations are 0.1’ 

before the desired beginning station and 0.1’ after the desired ending station.
 <Apply> and data to accept.
 Repeat as necessary to complete the special ditch vertical alignment.
 Geometry > Vertical Element > Check Integrity must be executed to verify that any added 

vertical elements are in the correct order, by station.

The template library component has a special ditch to be searched.  If a special ditch alignment is not 
found, the component will go to the next component entry, which is a standard or sloped ditch, followed 
by components for a fill section.  In doing this, a special ditch can be created without changing the 
components each time.  Corridor > Template Drops  <Double click> on template in the current template 
drops box which opens up Editing Roadway Designer Template Drop. Template Library bottom tab 
make Active Template, in the network tree you can data on the components (Example: <Double Click> 
R_Special Ditch 1 which is the right special ditch and it will highlight Component Properties)  Verify End 
Condition Properties as Target type alignment elevation Horizontal Alignment mainline Vertical 
Alignment special ditch right and offsets vertical 0.70. Complete for left side L_Special Ditch 1.

 The special ditch vertical alignments must be fully created prior to creating a surface.  

When the creation of the Roadway is complete, save the Roadway Corridor and File save as 
PCN#.ird.

Editing Between Transitions: From 2 to 4 Lane 

The edit transition command allows you to interactively modify existing backbone transitions between two 
template drops.  The backbone is considered to be the component of the template that is not an 
end condition or child component.  The Roadway Designer makes connections based on 
matching point names between transition templates and then allows you to adjust it as desired.

 The Roadway Designer>Tools>Options>Display Transition Graphics option must be turned 
on to view transition graphics.

 Roadway Designer Corridor   Mainline    Active Surface  PCN#org   right bottom, select the 
Process All button.  This action processes all stations of the corridor and updates all the display 
windows with the results. Close the Results dialog.  A brown bar appears at a template drop 
station. Notice a yellow shape between two template drops. This shape represents a transition 
region (shifting from 2 lanes to 4 lanes). The yellow indicates that some, but not all, of the points 
have been connected and you have not yet reviewed the transition.

 <Double Click> anywhere on the yellow shape.  In this 3D view of the backbone transition, 
notice that the thick red points symbols (+) are points that have not been connected to a point at 
the other end of the transition. Move the template to get a better view of how the points are 
connected.  To move a template, right click over one of the template points and select the Move 
Template command. Notice how you can pause the mouse over a point to display the point 
name.
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 To add a transition connection, left mouse click over the point (you must connect from the 
“unconnected” to the “connected”).  Multiple points can connect to a single point.  If you make a 
mistake or want to change connectivity, right click over the transition and select Delete Click OK 
on the Edit Transition dialog. Click OK on the reminder box that notifies the user to delete the 
appropriate constraints in order for the transitions to work properly. In this cross section view all 
of the features are shown in a cross section view. Each point shows the constraints as they were 
set up in the original template library. Right click on the points that need to be transitioned and 
delete the appropriate constraint. A transition slider bar along the bottom of the window will show 
how the transition is being performed over the given station range. In the roadway Designer 
dialog box, notice the yellow area in the transition is now dark blue. This indicates that all points 
of the transition are connected. Transitions should be verified as needed.

 Roadway Designer   Corridor   Mainline    Active Surface  PCN#org   right bottom, select the 
Process All button. Other visual cues for transitions are red, indicating none of the points are 
connected, light blue, indicating the transition has been reviewed or edited, however, one or 
more points remain unconnected.

When the creation of the Roadway is complete, save the Roadway Designer and File save as 
PCN#.ird.

Roadway Designer Right click in the cross section box and select Display Properties.  Select the 
settings you prefer and click OK
When working with templates and superelevation dialog boxes, it may be desirable to set the slope format 
to 0.50 so cross slopes read as 0.02 versus 50%. 

 File > Project Options
 Select the Units and Format tab.
 Under Format Select the Slope drop down menu and select 0.50.

 <Apply> <Close>  

Superelevation
Superelevation is used to control the cross slope of roadways in areas of horizontal curves.  In roadway 
designer superelevation control lines can be created and then used as vertical point controls to control 
the elevation of a point relative to another point in the cross section.

Modeler > Roadway Designer 

 In the bottom right corner, toggle on Superelevation display mode.  The superelevation 
diagram is synchronized to display the same station range as the profile view.  The plan, 
profile, and cross section view now show cross slope values of the backbone of the template. 
(Hot) Colors from yellow to red indicate increasing slope from left to right. (Cold) Colors from 
green to blue indicate increasing slope from right to left. White indicates a cross slope at or 
near 0%.  A typical normal crown section is Yellow / Orange on the Left and Green / Blue on 
the Right.

Superelevation > Create Superelevation Wizard > Table

 <Browse> from Table Wizard to find C:\dot\rd\data\06sd__.sup. Open the Rate Table that 
corresponds with the design speed as defined in the scope document.
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 Toggle on Percent Total on Tangent and set to 80%.  Transition Lengths Are: Toggle Total 
Transition.  Select Load Values from Table in Selected Curves Tab (Click on the box to load 
the values).  Select <Next>

 In the Superelevation Section Definitions dialog box, Select Add  under Sections to add a 
section to be superelevated.

 In the Add Superelevation Section dialog box, Crown Point: select Centerline, Left Range 
Point: select L_Subgrade (or urban section use point along front of gutter so the segment 
under the c&g does not superelevate), and Right Range Point: select R_Subgrade (or urban 
section use similar as discussed above for the left side).  Pivot Direction: From Crown Point 
(for Two Lane Roadway or where applicable).  Number of lanes: Toggle Two.  Runoff Length 
Multiplication Factor: 1 (or number from RD Manual if more than 1 lane to be rotated).  
Station Limits can be left toggled off to cover the entire horizontal alignment. Select <OK>.

 In the Superelevation Section Definitions dialog box, to view the basic superelevation 
information for each curve, highlight the curve under Superelevation for Selected Section and 
Select Edit.  Select <Close> to exit.

 Back in the Superelevation Section Definitions dialog box, Select <Next> to proceed.
 The Superelevation Controls dialog box shows the final superelevation controls that have 

been created.  Select <Finish>
 The superelevation wizard completed the design task of creating control lines for each point 

to be superelevated.

If you need to model superelevation which does not follow the standard tables, keep in mind that creating 
your own table specific to your projects parameters is an option.

The superelevation process will need to be repeated if the horizontal alignment is modified or restationed 
after the completion of superelevation.

SAVE !!  When the information is worth saving – Save It.

Import Superelevation from ASCII is another method available to model superelevation using the 
following steps. This method is simple and useful where the desired superelevation does not follow 
standard tables and needs to be input manually.

Create ASCII file
 Create *.txt file in Notepad with each line having the following format.
 Station (tab) Left Grade (tab) Right Grade 
 Grades are in ft/ft with positive and negative values based on direction from the crown point.

Modeler > Roadway Designer > Superelevation > Import Superelevation from ASCII
 File: <Browse> to *.txt file created above.
 Section: Input “1” for the first curve, “2” for the second, etc.
 Select Crown Point, Left Range Point and Right Range Point (See Note below)
 Apply
 Note: It appears this method does not apply the superelevation to all the points between the 

crown and the range points, therefore, the *.txt file must be applied to all the points that need 
to be superelevated. For a typical rural 2 lane road the ASCII file needs to be imported 3 
times by changing the range points to do the lanes, then shoulders, then subgrades.

Editing Superelevation

Modeler > Roadway Designer > Display Mode: Toggle on Superelevation
In the bottom right window of the Roadway Designer, 
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 Right click on point, Select Edit Point, Select Subgrade
 Superelevation Point Properties: Edit station and cross slope or others as needed. 
 Repeat for all the points that need to be edited. May also need to change points at the same 

location as Subgrade, such as Lane and Shoulder, etc. Verify in the view.
OR
 Right click in bottom right window
 Select Edit Curve Set Stations
 Edit stations and cross slopes. Toggle off Constrained where needed to change items.
 This method of editing cannot do all the points so the above method needs to be used to 

finish the editing.

Deleting Superelevation

Modeler > Roadway Designer > Corridor > Point Controls 
 Select the control(s) from the table
 Select Delete in the bottom right corner

Modeler > Roadway Designer > Display Mode: Toggle on Superelevation
In the bottom right window of the Roadway Designer, 
 Right click control line, Delete Control Line
 Repeat for all control lines to delete.

Superelevation > Apply Shoulder Rollover Lock  

This section is a work in progress.  After one or more individuals has had a chance to work on 
a rural divided roadway with superelevation, the design process for this section will be 
updated and the template points will be updated with correct terminology.  The process 
written below was written for a two lane roadway with the Range Points set at the edge of the 
driving lanes.

For Two Lane roadways, Shoulder Rollover Lock should typically not be necessary.  For Four Lane 
roadways, it may be necessary to utilize this design tool so that the entire subgrade surface rotates 
as necessary in superelevated sections.

Shoulder Point: LOS  Set Difference for both High Side and Low Side to 0.  Toggle on Match 
Transition Slope.  Leave the High Side Maximum Slope and Low Side Minimum Slope toggled off. 
<Apply>  Repeat the process for Shoulder Point: ROS. <Apply> again.  <Close> the dialog box.

 Process All

 Modeler > Roadway Designer > Superelevation > Superelevation Report  Report At: 
Toggle All Processed Stations.  Select All Available Superelevated Points (LEP, LOS, REP, 
ROS).  <Apply>  Review data to verify accuracy.  

 Note:  For the LOS & ROS, the high side shoulder begins rotating prior to the driving lane 
(from 4% to 2%) to match the slope of the driving lane.  This rotation occurs prior to the 
calculated beginning station of the superelevation based upon the rate of change for the 
curve.  For example: 70 mph design speed, 4.0% superelevation rate, transition length = 
180’.  The 2.0% shoulder change would occur over 60’ = (.02 / .06) x 180’.  This transition 
would occur within the 60’ prior to the typical Begin Superelevation Station.   

Note:  For the LOS & ROS, the low side shoulder holds at 4.0% until the inside driving lane has rotated to 
a point where it is also 4.0%.  For the example listed above, the low side shoulder would not rotate at all 
since the superelevation rate for the curve is 4.0%.
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Defining End Condition Exceptions

End condition exception is an efficient method of modifying the behavior of an end condition solution 
without making additional template drops.

 Roadway Designer bottom right corner toggle on Normal display mode. Corridor< End 
Condition Exceptions 

 Select Station Range start and stop    Apply to  Override or Transitions <Add>
 Highlight the new entry, select Edit or <Double Click>,  the Create Template command is 

activated to an Override box 
 Move cursor to the point you want to override and right click to move point, delete, etc. 

however you want to change that point.  <Click> OK in Override box  &  Close to  End 
Condition Exceptions

SAVE !!  When the information is worth saving – Save It.

Parametric Constraints
Parametric Constraints allow for flexibility to vary a specific constraint on a point without creating 
additional templates. These are useful when adjustments need to be made for a short stretch such as a 
right turn lane or left turn lane in a median section. Another great use of this is the ability to increase the 
surfacing thickness quickly instead of having to change the template which may result in changing 
multiple templates. This saves time overall and can be adjusted as necessary.

To set up a Parametric Constraint, the first thing that will be needed will be to have needed constraints 
labeled inside your template. Once this is done, different parametric constraints can be added:

 Modeler>Roadway Designer
 Tools > Template Library or click on Template Library button
 Select the appropriate template
 Edit the point that needs to have a parametric constraint added
 Under Constraint 1 or Constraint 2 there is a box for Label: Type a logical name here such as 

Lane or Finish depending on the constraint being labeled. You will need to reference this 
name in a future step

 Click <Apply>
 Make sure to save your Template Library before you exit the Create Template screen
 Select the appropriate corridor
 You will also need to make sure that your template drops are synchronized with your 

Template Library so the constraint labels show up
 Now still in Roadway Designer select Tools > Parametric Constraints 
 Select the appropriate Constraint label from the drop down box
 Input the start and stop station limits that the parametric constraint is taking place over
 Input the Start Value and Stop Value which is referenced from the point that the label was 

made from inside the template. For example: A 12’ wide lane from the template may be 
widened out to a 24’ lane for a right turn lane. The Start value would be 12’ and the Stop 
Value would be 24’. For the left side of the template a negative value is needed.

 Click <Add>
 Repeat this process as needed

SAVE !!  When the information is worth saving – Save It.
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Point Controls
Point Controls allows for the flexibility to model a roadway with varying geometry, without creating 
additional templates. Point controls are similar to Parametric Constraints in that it can allow a point name 
from the template to be altered from the standard template. Where they differ is that when using Point 
Controls the point will follow a horizontal alignment, vertical alignment or both over a set station limit. This 
is useful if a point in the ditch would need to follow a certain alignment that may differ from the mainline 
alignment. It could also be used for a lane point to follow a curve that differs from the rest of the mainline. 
There are many uses for Point Controls and is a powerful tool.

To set up a Point Control:
 Set the appropriate horizontal and vertical alignments active.
 Modeler>Roadway Designer
 Select the appropriate corridor
 Corridor >  Point Controls or click the Point Controls button
 Select the appropriate point name (the point that is to vary to meet the needs of the 

geometry).
 Toggle the desired mode (Horizontal, Vertical, or Both)
 Drop down the Control Type to use: Alignment, Feature, Style, or Corridor Point (In most 

cases Alignment will be used)
 Select the appropriate Horizontal Alignment (this will be other than the active horizontal 

alignment if a separate alignment has been created for the sole purpose of utilizing Horizontal 
Control). If the Mode is seeking a vertical alignment than choose the Vertical alignment as 
well.

 Input the appropriate Station Limits / Start and Stop stationing.
 Input the appropriate Offsets if needed. This will be the offsets from the alignment that the 

point is seeking, not the mainline alignment.
 <Add>
 Repeat the process as necessary for each additional entry.

Note: If you have superelevation applied to the corridor already then those superelevated points will show 
up in the list here as well. Scroll down to see your newly added point control. You can also click on the 
point control you created and edit them.

SAVE !!  When the information is worth saving – Save It.

Creating the New Surface
Typically, the end result in the Roadway Designer is the generation of a new design surface form which 
plan, profile, and cross section drawings are created.   Using the Corridor< Create Surface command

 Roadway Designer             Corridor    Mainline           Active Surface   PCN#org
 Create Surface dialog box     Create surface from Mainline
 Click <Apply> then <Close> Results dialog and the Create Surface  <Close>  Roadway 

Designer
 Save surface Mainline   Review your surface mainline

If you need to save the display of triangles or contours, create a separate graphics file (cPCN#.dgn), 
which can then be attached as a reference file as needed.
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 Surface > View Surface > Contours
 Select the appropriate Surface.
 For large projects, establish a fence and set Fence Mode to the appropriate setting.  The 

fence must be established prior to executing the View Surface command.
 Set Interval and Minors per Major to the desired settings.
 Edit the <Preferences…> and Symbology as needed.
 <Apply>

And/or

Surface > View Surface > Triangles
Select the appropriate Surface, Fence Mode, Symbology and <Preferences…>.

If a surface is viewed temporarily in a file, delete contours or triangles when done and compress the 
graphics file.
The fence mode is useful for large projects because it can limit the contours or triangles to an area inside 
the fence.

Feature 
The two most common uses for Features is for annotating cross sections and for attaching cells (such as 
the curb & gutter cells) to cross sections.

As directed earlier in the Create Cross Sections section of this document, toggle Include Features off 
when creating a cross section set.  If it is desirable to include the features, generally only the subgrade 
features that represent the exterior boundary, special ditch elevations, and curb and gutter features need 
to be turned on.   It is good practice to keep the number of features displayed in the cross sections to a 
minimum as displaying features can cause the file to become very large.  

To attach cells to features

 Tools > Named Symbology Manager
 Select the appropriate feature code from the list displayed in the dialog box.
 <Edit>
 Select Cross Section Point.
 <Edit>
 Set Display As to Cell.
 Set Level to the appropriate level.
 Set Cell Name to the appropriate cell to be associated with the feature code.

The proper cell library must be attached to the MicroStation design file prior to executing the Symbology 
Manager command.

 Verify that X Scale, Y Scale and Z Scale are properly set.  Some cells require that the Y 
Scale be set to 0.50, while the other scales remain at 1.00.

 <OK>
 <Apply> and <Close>
 <Close>

These cells will now be displayed with the corresponding feature code, when the feature codes are 
displayed in the cross section set.

Cells associated with feature codes will be removed or added from the display in the cross section set, as 
their parent feature code is removed or added.
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Create Cross Sections

Cross sections will be drawn in a separate graphics file (xPCN#.dgn). 

 Surface > Surface Properties…
 Select the Advanced tab.

 Select the appropriate Surface.
 Select the corresponding Cross Sections Symbology.
 Select the corresponding Profiles Symbology (this will be useful when creating 

approach pipe sections).
 <Apply>

Two separate cross section sets will be created for two separate purposes:

1. The Plans Cross Section Set – This set will be created for plotting and will include annotation 
and a plans border.  The Undercut surface will not be displayed in this set of cross sections 
unless requested by the Area Office.

2. The Volume Cross Section Set – This set must show the entire range of cross sections and 
all surfaces necessary for volume computations.  The actual earthwork volumes are 
calculated from the elements created for each surface in the graphics file.

Open the original ground surface (PCN#org.dtm), the geometry (ePCN#.alg) and the appropriate design 
surface (Mainline)

 Evaluation > Cross Section > Cross Sections…
 Open the Create Cross Section Folder.
 <Preferences…>

 Plans Cross Section Set – Set the appropriate preferences to 10_20_portrait, 
20_40_portrait, 10_20_landscape or 20_40_landscape.

 Volume Cross Sections Set – Set the preference to volumes
 Open the folder Create Cross Section.

o Under General
 Set Name will default to the horizontal alignment name, and will change by an 

increment of 1 (mainline_1, mainline_2, etc.) for each subsequent cross section 
set created.  Modify this entry to (volume) for the Volume Cross Section Set.

 Open the Source subfolder turn on Alignment and select the appropriate 
horizontal alignment.

o Under Controls
 Modify the Limits settings as needed.  (The Station limits will be ignored if 

entries are created under the Custom tab).  

 See Cross Section Reports later in this document for details on creating a cross section 
report during the Create Cross Sections process.

 Return to the Main tab.
 <Apply> and data point a position in the graphics file.
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 The cross section Interval must be at the same interval (or multiple of interval) that the 
template was dropped.  If it is not, the design surface may not tie to the original ground 
on the cross sections. The cross section Interval shall be set to 100.00 feet for rural 
projects and to 50.00 feet for urban projects or mountainous terrain.

Cross-Section Viewer
 Evaluation > Cross Section > Cross Section Viewer
 Select the appropriate Cross Section Set.  A fence with the active MicroStation properties will 

display around the selected cross section set.
 Modify the Zoom Factor as needed.
 <Run> and data the appropriate view (ESC to stop the display while running).

Update Cross Sections
This command allows the user to update the surface graphical elements following the execution of the 
Roadway Modeler command, without having to recreate cross sections.

Features must first be removed from the cross section set before surfaces are refreshed.  To 
remove features, follow the steps listed below, selecting Display Off instead of Refresh and the 
appropriate features listed in the Object / Feature window in conjunction with the appropriate 
surface.

 Evaluation > Cross Section > Cross Sections
 Select the appropriate Cross Section Set.
 Open the Update Cross Section Folder.

o Under General
 Toggle on Refresh to update the surface graphical elements.
 Set Limits / Station Range as needed.

o Under Surfaces
 Select the appropriate surfaces.

 <Apply>

This command is also used to toggle on or off features for annotating the cross sections.

Annotating Cross Sections 
 Evaluation > Cross Section > Cross Sections…
 Select the appropriate Cross Section Set.
 Open the Update Cross Section folder. 

o Under General
 Toggle the Mode:/Display On. 

o Open the Crossing Features subfolder. 
 Select the appropriate Surface followed by the appropriate Features. 

 <Apply>
 Open the Annotate Cross Section Folder.           Select Preference

o Under General subfolder 
 Select the appropriate Surfaces.

 Open the Features subfolder 
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o Under Annotate (In the Features subfolder).
 Select all features by opening Filter… and toggle on Start with:/All and press 

<Ok>
 <Apply> and <Close>

Annotate Storm Sewer Flowline Elevations
 Drafting > Place Cross Section Note > Storm Sewer

Exterior Boundary, Left Subgrade and Right Subgrade are annotated using the 10_20_scale or 
20_40_scale preferences.  Special Ditches are annotated using the Left Special Ditch and Right Special 
Ditch preferences.  Note that the Special Ditch preferences are configured for the 20_40 scale cross 
section sets.

Once the cross section set has been annotated return to the Update Cross Section command, Toggle 
Mode: / Display Off and follow the remainder of the steps for displaying features outlined above to “turn 
off” the features.  This will remove the feature graphical elements from the dgn.

Plotting Cross Sections
To plot cross sections in .pdf format follow the steps in the link below. 
https://dotfiles.sd.gov/cadd/ElectronicPlans.pdf

Pipe Cross Sections
Mainline Pipe Cross Sections
Open the geometry project (ePCN#.alg) from the project folder, and set the appropriate horizontal 
alignment active.

 Place horizontal event points at all proposed mainline pipe locations.
 Geometry > Horizontal Curve Set > Events…
 Set Define By: to Single Station.
 Toggle Add As / Station and Offset.
 Enter the pipe station in the Locate By / Station field, leaving the Offset field set to 

0.00.
 <Apply>
 Repeat until all pipe locations have been entered.
 <Close>

 Modeler > Roadway Designer…
 Create a new surface under Roadway Designer > Corridor > Create Surface…
 Select the appropriate surfaces. 
 <Apply>
 Create a new Microstation 3D graphics file, saving it as pPCN#.dgn in the project folder.
 Evaluation>Cross Section>Cross Section…

 Set the Preference to 10_20_Landscape.

 Hint: Under the Controls>Criticial Sections tab, turn off Horizontal Event Points 

Create a separate pipe cross section set for the 20_40_Landscape preference as needed

 Open the Create Cross Sections folder followed by the Custom subfolder
 Select the Custom tab.

 Select Perpendicular or Skewed as the Type.

https://dotfiles.sd.gov/cadd/ElectronicPlans.pdf
https://dotfiles.sd.gov/cadd/ElectronicPlans.pdf
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 Enter the pipe Station: and Skew Angle: as appropriate as well as the Left Offset: and Right 
Offset: corresponding with the previously selected preference.

The Skew Angle: is positive for Left Hand Forward and negative for Right Hand Forward.

 <Add>
 Repeat until all pipe sections have been entered.
 Save the custom pipe section set as pipe10_20.xsc (or pipe20_40), in the project 

folder.
 <Apply>

To delete the custom cross sections, highlight the cross section you want to delete, then hit the Delete 
Key.

The custom pipe section set can be recreated at any time, by loading the .xsc file from the project folder 
(Control File / File Name). 

Following the creation of the pipe cross sections, load the XPIPE MDL application to draw each individual 
pipe. (MicroStation Utilities > MDL Applications).

Approach Pipe Cross Sections

 Open pPCN#.dgn.
 Load the XSECT cell library and place the cell ENTL or ENTP.  If you are using the ENTL 

cell, the station range is 320 feet.  If you are using the ENTP cell, the station range is 200 
feet.

 Evaluation > Profile > Create Profile…
 Set Preferences to appr_pipe.

o Under General
 Select the appropriate Surfaces. 
 Toggle Direction / Left to Right on for entrances on the left and Direction / 

Right to Left for entrances on the right.
 To Set Offset: Highlight the appropriate Surface and select properties:

 Set the Profiles/Symbology: 
o <Surface Properties…>

 Select the Advanced tab.
 Set the appropriate Surface.
 Set the appropriate Profiles / Symbology to 

Subgrade.
 Set the pipe Offset / Distance from mainline (-) for 

left and (+) for right.
 Set the Offset / Symbology to Appr_Pipe.
 <Apply>

o Under Controls
 Toggle Station on and select a start station that is ½ the cross section limit 

ahead and a stop station that is ½ the cross section limit back of the entrance 
location.

o Under Offsets
 Check on the appropriate Offsets:

 <Apply>
 Data a green point on the left side of ENTL or ENTP for an approach pipe left of mainline or 

data a green point on the right side of ENTL or ENTP for an approach pipe right of mainline.

Following the creation of the pipe cross sections, load the XPIPE MDL application to draw each individual 
pipe. (MicroStation Utilities > MDL Applications).
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Compute Cut and Fill Volumes using End Area Volumes
Open the cross section file (xPCN#.dgn), the appropriate geometry (*.alg) and surface (*.dtm) files.

 Evaluation > Cross Section >Cross Sections > End-Area Volumes Folder
 Select the appropriate Cross Section Set.
 Select General Tab >

 Select the Original Surface (PCN#.org)
 Select the appropriate subgrade Design Surface.
 Toggle Imperial Units to Cubic Yards.
 Toggle Method to Correct for Curvature.
 Toggle Plot Mass Haul Diagram.
 Toggle Create XML Report. (When an End Area Volume is run a XML Report will 

automatically open if this options is checked.)
 Select Classifications Tab> 

 Set the following for all the Undercut Components.
 Classification> MDC
 Mass Ordinate> Include
 Fill Factor> Shrink value (Enter appropriate shrink value for each undercut based on 

specified station ranges. In order to have different shrinkage values for the undercut, 
the undercut component name and symbology will need to be changed for each 
shrink value with names such as UndercutA, UndercutB, etc.)

 HINT: The cross section set that the volumes are being calculated from should only 
have the undercut components displayed. Displaying other components such as the 
finished surface, sidewalk, etc. can cause issues with the values in the volumes 
report.

 Select Compaction/Expansion Tab>
 Settings> Start/Stop Stations> Station Cut/Fill Factors: This option allows the user to 

input project specific shrinkage or swell.
 Select Volume Exceptions Tab>

 Settings> Start/Stop Stations> This option allows the user to select a portion of the 
model, which will not be included in the volume quantity (grading exception).  When 
using this option for excluding bridges, the start and stop stationing must be the toe 
of the fill slopes.  Volume Exceptions are project specific.

 Select Added Quantities Tab>
 Settings> Start/Stop Stations> Toggle Type> Volumes & Factor> This option must be 

selected to enter additional cut and fill quantities.  Quantities such as borrow, muck 
and unstable, salvage and entrance volumes are entered here.  Shrinkage values 
must also be entered with each added fill quantity entry. When entering quantities 
over a station range, enter the total quantity for the station range.  Inroads adjusts 
this quantity per station. Added Quantities are project specific.

 Select Annotation Tab>
 Toggle on the appropriate Objects as necessary to annotate the volume cross 

section set.  This step is a user preference and is not required for calculating 
volumes. 

Save the above end area volume settings by File> Save As> Save in: Path to the project directory & File 
name: input based on the roadway alignment name. The end area volume file should be saved as a type 
(*.eav) with a name that matches the alignment, such as mainline.eav or xr105.eav. This file will need to 
be opened to make changes to any added quantities or other settings by File> Open.

Added Quantities and other above settings can be edited/added by opening the (*.eav) file mentioned 
above in a text editing software program such as Notepad or Wordpad.  Extreme caution should be taken 
when working with the Added Quantities in this manner, as the entries need to be in a specific order and 
numbered in a specific manner.
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Mass Haul Diagram
 Select Apply in the Cross Section Tab Identify point to plot in Microstation file or Reject
 Exaggeration / Horizontal: should be set to 0.50 and Exaggeration / Vertical: should be set to 

0.02.

Volume Reports
 Select Apply in the Cross Section Tab> Bentley Civil Report Browser> 
 Select SDDOT > SD_Volumes.xsl

Volumes.xsl could be used to verify MDC quantities for a check  
 File <Save As…> to save this report results to the project directory as 

u:\rd\prj\COUN\PCN#\endvol.html.

 Save the Roadway Designer and File save as PCN#.ird.

Appendix A – Developing an InRoads Project

An InRoads Project (*.rwk) file can be created, that can be opened at the beginning of each InRoads 
session.  This file gives the user the ability to open each desirable component of the modeling process 
without having to open each component individually. 

 Open the Surface files (*.dtm) for the project, beginning with PCN#org.dtm (from the REGION 
project folder), and then mainline.dtm files.

 Open the Geometry project file (ePCN#.alg).
 Open the Template Libraries file (PCN#.itl).
 Open the Roadway Design file (PCN#.ird).
 Open, if applicable, the Drainage file (PCN#.sdb).
 InRoads File > Save As
 <Options…>

 Select the Surfaces tab.
 Toggle Add for the PCN#org surface.  (Road Design does not have access 

rights to the Region project folders, thus Update must not be toggled on for 
this surface, as Update also saves any modifications to the component file, 
when the InRoads session is ended or the Project file is saved).

 Toggle Add and Update for the remainder of the surfaces.
 Select the Geometry Project tab.

 Toggle Add and Update for the Geometry Project.
 Select the Template Library tab.

 Toggle Add and Update for the Template Library.
 Select the Roadway Design tab.

 Toggle Add and Update for the Roadway Design.
 Enter PCN# in the File Name: field.

 <OK>

The InRoads Project file can also be created by copying u:\rd\Bentley\V8i\InRoads\data\English\rd.rwk to 
the appropriate project file.  Once the copy has been completed utilize a text editor program to edit the 
path for each respective component of the file.
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Appendix B - InRoads Storm & Sanitary Workflow, V8i
Table of Contents

Starting InRoads Storm & Sanitary
Storm Sewer Design Procedure
1.  Set preferences and symbology for network structures
2.  Lay out network structures
3.  Compute flow and attach drainage areas
4.  Design the network
5.  Create a profile
6.  Analyze the network
7.  Redesign the network and recreate a profile if needed
8.  View Network Layout
9.  Annotate the network structures
10.  Display Network on Final Profiles
11.  Annotating Drainage Profiles
12.  Storm Sewer on Cross Sections
13.  Generate reports

Starting InRoads Storm & Sanitary

Need to contact the HELP desk to have BIT install the software on your computer.

Loading Inroads Storm & Sanitary after software installed
Inroads toolbar: Tools > Product Add-Ins > check InRoads Storm & Sanitary box,  OK
This will add Drainage to the Inroads toolbar and also a Drainage > Options under Tools.
Save settings to have this automatically load for this project, but should toggle off when not in use 
since it checks out a license every time it is loaded.

Open Inroads Storm & Sanitary right away when starting Inroads if working on storm sewer. Opening 
the .itl and .ird files before opening Inroads Storm & Sanitary will cause these files to become 
inaccessible and will need to be reloaded again.  

Create Drainage (.sdb) file when first beginning 
File > New > Drainage Tab > 
Name: PCN# (will automatically add the extension .sdb)

Save Drainage (.sdb) file when needed

Open Drainage (.sdb) file  
File > Open > 
set Files of type: to Drainage (*.sdb), then select PCN#.sdb
Can also open the PCN#.sdb by adding to the PCN#.rwk file and opening only that.  

Be sure to have the project geometry and surface files loaded for InRoads Storm & Sanitary to reference 
from.

HINT: Be sure you have run Bentley Config Utility (BCU.exe), so your computer has the latest 
SDDOT standard drainage files loaded.   Recommend checking that the correct i_structure.dat 
file is loaded every time InRoads Storm & Sanitary  is used by looking under Tools > Drainage > 
Options > Inlet Tab, and that Type B is an option under class: when the type: is set to 
combination. 

Recommend creating sPCN#.dgn as a 3D graphics file in your PROJECT folder using microstation.
This file will be used to design the storm sewer system.



26

Storm Sewer Design Procedure

1.  Set preferences and symbology for network structures.

Most of the following are typical project settings that should automatically be loaded from the default 
preference, which is in rd.xin and loaded when BCU.exe (Bentley Config Utility) is run.  These settings 
should be double checked before placing structures and computing to meet project specific needs. 

Tools > Drainage > Options  

General Tab:
Drainage Structures File: sddot_ i_structures.dat (the program seeks this 

file from C:\dot\rd\data\sddot_i_structures.dat
which is loaded when BCU.exe is run)

Area Units: ac
Discharge Units: cfs
Status: Fixed for inlets,  Resize for pipe (See following hint)

HINT: Under the General Tab, Status: Fixed needs to be toggled while placing inlets, but should be set 
back to Resize when placing pipes to have the software resize pipes during the analysis.  If any inlet in 
the network is toggled to resize, InRoads Storm & Sanitary will produce an error message about inlet 
surcharging when analyzing the network.  It may be easiest to leave as Resize and edit the inlets after 
they are placed.  To change this after an inlet is placed, go to Drainage > Edit/Review, select the inlet, 
toggle on Fixed at the bottom of the Inlet Tab, Apply.
Structure IDs Tab:

Toggle on Use Prefixes
Prefix: Pipe: P

Channel: CH
Culvert: CV
Manhole: MH
Inlet: IN
Pump: PM
Area: A
Zone: Z
Utility: U

Gutter Section Tab:
Type: Composite
Gutter Width: 2.00 ft
Side Slope: 20.00:1  (.05 ft/ft)
Longitudinal Slope: Compute from DTM
Transverse Slope: Compute from DTM (usually 50:1 or .02)
Roughness: 0.015 (Set ‘n’ value based on 12.8-B in the Drainage Manual)
Maximum Spread 8.00 ft

Design Tab:
Design Equation: Manning
Structure:  Set parameters for each type of structure to be placed as follows:

Pipe:
Minimum Height: 18 in.
Maximum Height: 200 in.
Minimum Velocity: 2 ft/s
Maximum Velocity: 40 ft/s
Depth to Height Ratios:  (Used only when creating a Sanitary flow system)
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For Height up to: (in.) Use Ratio of:
15.00       0.50
150.00       0.75
999.00       0.93

Inlet: The following parameters are applied to all the appropriate inlets during the design
analysis of the network, as performed in step 4, and cannot be changed for different inlets 
during a single analysis.  The following values listed are for most typical uses of the 
standard inlet types, except a Type B-in sump.  To check a Type B-in sump, input the 
values listed farther below, and run a separate design analysis just for the non-typical Type 
B-in sump inlet results.

     Typical Inlet Uses  (Type B-on grade, all Type S & all Type C):
Curb Height: 6.0 in For typical curb & gutter sections like Type F & B. 

Does not include inlet depression.
Curb Opening 

Height:     6.1 in This parameter is only used for curb opening 
(Type S) and Combination (Type B) inlets in sump  This 
value should be the total opening height with depression 
below the gutter subtracted out (6.1”-3.4”=2.7”).

Curb Length: 3.00 ft Only used for Combination Inlets (Type B).
Normally this length should be the same as the grate 
length, so the curb opening capacity is neglected, as is 
standard design according to HEC22.  If the curb length 
is longer than the grate, then the extra length is 
assumed upstream of the grate, and flow is taken into 
only the extra curb opening length and then the grate.

Orifice Depth:    0.52 ft This parameter is used for all inlets except curb 
openings (Type S). This value is for a Type C inlet, 
Neenah R-3457-C2 B, and is the head where flow 
changes from weir to transitional flow on the Neenah 
website (www.nfco.com). Determines whether a grate is 
in weir or orifice flow in a sump location.  This is also 
depth where curb opening orifice capacity is added with 
the grates for a combination inlet (Type B).  This depth is 
compared to the gutter depth plus depression, however, 
depression cannot be input for grates in sump locations. 

     Type B-in Sump:  (will need to run a separate analysis with these parameters)
Curb Opening 

Height: 4.5 in See discussion above.

Orifice Depth: 0.49 ft From Neenah R-3067-V V.  See discussion above.
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2.  Lay out network structures

Drainage > Lay Out

HINTS: Place junction structures first such as inlets and manholes, then connect with 
pipes.

When placing inlets be sure the subgrade (mainline) surface is active, so the 
gutter section uses the correct transverse (typically 2%) and longitudinal slope, if 
computing slope from DTM.  These slopes are important when computing flows 
and spread.

When placing Type S inlets, be aware that the offset to the center of the inlet is 
behind the curb & gutter, so the subgrade surface is much higher than that below 
the roadway surfacing.  This may cause the program to set the initial pipe 
elevation too high at this inlet when it maintains the 1 ft. minimum subgrade 
cover over the pipe.  You will need to adjust the pipe elevation. Also adjust the 
inlet elevation accordingly based on the finished gutter or grate elevation.

Inlet Tab:
Options (Button at bottom):  Select and set the parameters needed as shown 

below under Options… before placing each inlet.
Inlet ID:         Set the number as needed or use automatic number.
Location:         Set as needed
Angle:        Will come in as set in Drainage Options, Inlet, Orientation
Long. Slope:        Will come in as set in Drainage Options, Gutter Section
Transverse Slope:    Will come in as set in Drainage Options, Gutter Section
Connecting Pipes:    Add connecting pipes if needed, not typically done.

Options (Button at bottom):  Takes you to Drainage Options, Inlet: 
(Can also get to this by Tools > Drainage > Options, Inlet Tab) 
Input the type of inlet you want to place with the different options and 
parameters listed as follow:

        Type B Inlet (On-Grade):
Type: Combination
Class: Type B
Grate Size (LxW): 3.0 x 1.5   (Choose the one that gives the vault size 

needed, as will show below, to fit pipe in)
Vault Shape: Box
Vault Size (LxWxT): 3 x 2 x 6  ftxftxin  (Change to size needed to fit pipe)
Placement Offset: 0
Location: On-Grade
Connection Point: Inside (pipe connects to center of inside wall)
Depression: 0.0 in
Drop Across: 0.0 ft
Maximum Depth: 10 ft (According to standard plate)
Depth below Invert: 0.0 ft
Grate Cover: 45 % (Percent flow is restricted by bars of grate.

Only used for orifice flow in sump)
Clogging: 0   % (Assume no clogging of inlets)
Intercept Flow: 60 % (Ignored since inlet size is set to fixed)
Orientation: Parallel to Alignment (Change as needed)
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        Type B Inlet (in Sump):   These inlets are typically not used in sump conditions, 
unless the gutter flow is 1.0 cfs or less.

Input the same parameters as above Type B Inlet (On-grade), except as follows:
Location: Sump
Stand Height: 0.0 ft
Intercept Flow cannot be input

Type S Inlet (in Sump):
Type: Curb Opening
Class: Type S
Opening Length: 5 or 10 (Choose the one that gives the vault size 

needed, as will show below, to fit pipe in.  
10’ lengths are generally used in sump.)

Vault Shape: Box
Vault Size (LxWxT): 11 x 4 x 6  ftxftxin  (Change to size needed to fit pipe)
Placement Offset: 0
Location: Sump
Connection Point: Inside (pipe connects to center of inside wall)

Depression: 3.4 in
Drop Across: 0.0 ft
Maximum Depth: 8’ and 10’ (Varies depending on vault size. Depths 

shown are from the top back of curb. From standard 
plates – 8’ for 4’x6’ & 4’x11’, 10’ for 7’x11’)

Stand Height: 0.0 ft
Depth below Invert: 0.0 ft
Orientation: Parallel to Alignment (Change as needed)

Type S Inlet (On-Grade):  These inlets are typically not used on-grade but may produce 
lower spread rates if the roadway profile is flatter. Input the 
same parameters as above Type S Inlet (in Sump), except as 
follows:

Location: On-Grade
Depression: 3.4 in (This is the depression below the gutter bottom 

just upstream of the inlet opening) 
Stand Height is not input

Intercept Flow: 60 % (Ignored since inlet size is set to fixed)
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Type C Inlet (in Sump):
Type: Median Drop  (this type uses 4 weir sides vs. 3 for 

grates)
Class: Type C
Grate Size (LxW): 4 x 3 (Choose the one that gives the vault size 

needed, as will show below, to fit pipe in)
Vault Shape: Box
Vault Size (LxWxT): 4 x 3 x 6  ftxftxin (Change to size needed to fit pipe)
Placement Offset: 0
Location: Sump
Drop Across: 0.0 ft
Maximum Depth: 10 ft
Stand Height: 0.0 ft
Depth below Invert: 0.0 ft
Grate Cover: 50 % (Percent flow is restricted by bars of grate

Only used for orifice flow in sump)
Clogging: 0   % (Assume no clogging of inlets)
Orientation: Parallel to Alignment (Change as needed)

Type C Inlet (On-Grade):   These inlets are typically not used on-grade.
Input the same parameters as above Type C Inlet (in 
Sump), except as follows:

Location: On-Grade
Stand Height: (No input)
Intercept Flow: 60 % (Ignored since inlet size is set to fixed)
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Pipe Tab:
Options (Button at bottom):  Select and set the parameters needed as shown 

below under Options… before placing each pipe.
Pipe ID: Set the number as needed or use automatic number.
Location:  Set as needed
Elevations From: Soffit.    Toggle on to align inside top of pipe, resulting in 

abrupt drops in flowline.  If not toggled, pipe flowlines will 
be aligned. See SD Drainage Manual for best method to 
use.  Generally,   hydraulic characteristics are better 
when top of pipes are aligned.  Aligning pipe at flowlines 
is typically done in flat terrain. This toggle will be used by 
the software to initially set the pipe elevations.  When 
individuals adjust the pipe elevations manually, as is 
typically always needed, they will need to match soffits 
themselves, if so desired.

Invert In, Invert Out 
& Slope: Set these 3 parameters as desired.  

The software analyzes the pipe at these elevations, and 
does not automatically adjust during the design analysis.  
Users will need to review the initial elevations set by the 
software, and adjust as needed for better flow 
characteristics and meet cover requirements. One 
parameter will need to be fixed.  To fix one correctly: 
toggle it off so it can be edited, type in what you want to 
be set, then toggle it on.  Edit one of the other 
parameters as desired, and it will automatically update 
the last.

Options (Button at bottom):  Takes you to Drainage Options, Pipe: 
(Can also get to this by Tools > Drainage > Options, Pipe Tab) 
Input the type and size of pipe you want to place with the parameters 
listed as follows:

Shape: Circular, Box, Elliptical or Pipe-Arch   (select from available)
Material: RCP, CMP or PVC       (select from available)
Size (_x_xT): (select desired size from those available, listed in inches)
Min. Slope: 200:1
Max. Slope: 5:1
Min. Cover: 1.0 ft
Max. Cover: 20  ft (Check max. cover from SD Drainage Manual) 

After drainage structures are placed they can be changed by:
Drainage > Edit/Review , then select structure to be edited

(or can right click on the structure ID and select Edit/Review under the InRoads window)
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3.  Compute flow and attach drainage areas.

Create shapes of the drainage areas flowing to each inlet in the network using microstation tools such as 
Place Smartline.

Tools > Drainage > Options

Area Tab:
Rainfall Method: IDF File  (See below)
Frequency: 10 yr 
Time of Concentration: Kirpich: 0.0078 (rounds to 0.01) as the regional constant
Runoff Coefficient: Can input a value or hit the Compute (button) to 

determine a value that will be used as the default for all 
the areas in the network.  Typically the Runoff 
Coefficient will be input or computed separately for each 
drainage area under Drainage>Flows>Compute Flow 
and not at this location.

IDF File: The appropriate idf file (rainfall intensity duration frequency data), used 
to compute the flows by the rational method, will need to be set in the 
project defaults by the following:

File > Project Defaults, with the cursor in Rainfall Data, select Browse…, go to
C:\dot\rd\data\ to select the correct CITY.idf file based on the location in 
the state.  See the SD Drainage Manual (Fig 7.13-G) for the city to use.

HINT:  Whenever flows are to be computed, double check that the correct 
rainfall data file (City.idf) is selected in the project defaults. The project 
default should keep the same rainfall city until it gets changed.
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NOTE:  If the designer wishes to calculate flows for a storm frequency other than what 
was originally specified (i.e. 100 yr storm vs. 10 yr storm) the following steps 
need to be followed.
1. Under the Tools > Drainage > Options > Area tab change the frequency to 

the desired storm.
2. Under each of the established drainage areas (Edit/Review Area), toggle 

from the Time of Concentration data box to the Intensity data box.  Storm 
intensities will update with this step.

Simply changing the storm frequency under the Tools > Drainage > Options > 
Area tab will not change the rainfall intensities for the drainage areas.  Each and 
every established Area data set will need to be updated as listed above.

Drainage > Flows > Compute Flow  - Computes flow from drainage areas and inputs into the 
network.

Options (Button) can set the parameters as explained previously for 
Tools>Drainage>Options. Recommend double checking that the 
correct city.idf file is used.

Rational Tab:  (Q=CIA)
Area ID:  Use automatic number or input a number.  

May want to match the Area ID to the corresponding 
Inlet ID.

Drainage Area: Click the Locate button and select graphic shape of the
drainage area as created above, or input area in acres.

Runoff Coefficient:  Compute based on land use values and % of use, as 
shown below under Compute Runoff Coefficient, or 
input a value.

Time of Concentration: Toggle on and typically input the minimum 5 minutes or, 
Compute Time of Concentration as shown below for 
larger areas 

Intensity: Don’t toggle on. 
The intensity from the specified City.idf file will be used.

Peak Flow: Shows computed value based on above parameters.
Attach To: Click the Locate button and select the inlet or pipe that 

this drainage area will flow to.

Compute Runoff Coefficient:
File Name: C:\Program Files\Bentley\InRoads Group 

V8.11\data\runoff.dat
Rainfall Frequency: 10 yr
Runoff Coefficient: Shows the coefficient of the highlighted land 

use. Note: The coefficients change for different 
frequency.

Land Use %: Input the percentage of each type of land use in 
the drainage area, until there is a total of 100% 
below.

Total %: Automatically adds up all the Land Use % input.
Needs to be 100% before computes composite 
coefficient.

Composite Coefficient: Computed runoff coefficient based on land use 
%.
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Compute Time of Concentration:  Use to check if the following Result is 
greater than 5 min.

Method: Overland Flow

Drainage > Flows > Inject Flow (or Drainage > Edit/Review > Flow Tab, Injected Flow:)
Injects flow into a network where needed instead of computing flow from an area.

Note: When injecting flow into an inlet, the flow will first go into the gutter and spread 
will be computed from the injected flow.  To inject flow directly into the inlet 
without first going into the gutter, then create a small pipe into the inlet and inject 
flow into the pipe.

Bypass flow interceptor needs to be set for each On-Grade inlet in the network by the following:

Drainage > Edit/Review,  select structure to be edited, 
or can type in the structure ID in the Microstation  key-in window.

Gutter Tab:
Bypass Interceptor ID:  Select structure that the bypass gutter flow will 
flow to. Apply



35

HINT: Recommend double checking all the inlet, gutter and flow parameters before the next step of
designing the network.
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4.  Design the network

Drainage > Network > Design   

Toggle on “Tree Network Containing:” under Structures, and select any structure in the 
network to be analyzed.

Toggle on “Generate Design Log”

Toggle on “Enable Time of Concentration” 

“Capture all flow to inlet, ignoring Inlet capacity calculations”:
The network should be analyzed twice, first with this toggled off and then 
with it on. This follows the method recommended in HEC22. 

Toggled Off analysis is needed to accurately compute gutter flow 
spreads at the inlets.  By not toggling this, the inlet gutter bypass flows 
will be computed and added to the downstream inlet gutters, resulting in 
more accurate spread computations.   

Toggled On analysis is needed to compute pipe sizes.  Pipes should be 
sized assuming all flow enters the inlets and no bypass flows are 
computed.  This may result in slightly larger pipe at the upstream of a 
network.

Note: Do not toggle “Use Depth to Height Ratios”.  These are used for sanitary 
flows. This could be used for storm sewer if there was a special need to 
limit the depth of water in the pipes.  If so, these ratios are set in the 
Drainage Options > Design tab.

Note: Peaking Factor Method: is not applicable, since it only pertains to 
sanitary systems.

Toggle on Generate HGL and EGL.  

Toggle on “Use Water Depth” under Outfall Water Level, unless the outfall water level is 
known.

Toggle on “Greatest Flow” under Trunk Line Path

Ke for Outlet Control Pipes from Drop Manholes:  0.5

Options (Button):  To easily change design settings or double check that the settings are 
correct. The settings should be double checked, especially the rainfall 
city.idf file.

Apply
If prompted “Bypass flow found from a downstream structure. Do you want to redesign to 
account for this flow?” Select Yes. This will include bypass flows that were assigned to 
inlets that may be downstream of the structure but are actually higher in elevation due to 
the roadway profile. (Storm sewer trunk line goes in opposite direction of roadway grade)

Save Results (Design Log)

Notes: Using InRoads appears to give slightly conservative spread rates.  It may be good practice to 
double check a few spread rates using other HEC22 based software such as Hydraulic Tookbox. 
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5.  Create a profile

Evaluation > Profile > Create Profile
Load the Storm Preference

Under Create Profile:
Select Source Leaf:

Toggle on Network
From: & To: Select Structures that you want displayed on the profile.
Toggle on “Existing Profile” under Drainage Network Reference.
Apply (Button). InRoads will prompt you to > Identify Profile. Data click 

on the profile that you want the storm sewer displayed.
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6.  Analyze the network

Analyze the network by reviewing the design log and network profile that were created as above.  

Design Log: The design log was created as above by toggling on Generate Design Log when 
designing the network under Drainage > Network > Design.  

Review the design log for warning messages such as: spread greater than maximum spread.

The bottom of the design log shows HGL/EGL Computation Results.  Review these and the profile to see 
that the HGL & EGL meet criteria discussed in the Road Design Manual, Drainage Chapter 11.  Some 
criteria to meet include: keeping the HGL below the finished roadway surface and having correct values 
for the outfall. HGL is a red dashed line on profile and EGL is a green dashed line.
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7.  Redesign the network and recreate a profile if needed.

Make changes to the network to correct problems found in the design log and profile.

8.  View Network Layout

Drainage > View > Drainage

9.  Annotate the network structures.

Do this for your information only during design.  Not to be shown on plan sheets.

Drainage > View > Annotate Structures
This can be customized to show any information needed.

10.  Display Network on Final Profiles

For this step, you must receive permission from the drafter to use the dPCN#.dgn.  You also need 
to open the dPCN#.alg in order to annotate the profiles in the d file.

Evaluation > Profile > Create Profile

Load the Storm preference.

Under Create Profile:
Select Source Leaf:

Toggle on Network
From: & To: Select Structures that you want displayed on the profile.
Toggle on “Existing Profile” under Drainage Network Reference.
Apply (Button). InRoads will prompt you to > Identify Profile. Data click 

on the profile that you want the storm sewer displayed.

You will need to select each individual profile that you want to show the 
storm sewer on so that it displays correctly on the profile sheet.  

Note: More often than not, the branch lines will not show up on the profile.  The branch lines 
that do not show up will need to be drawn separately by selecting the network structures 
From: and To: for the branch line only.

Hint: Once you have the storm sewer on each profile, and you make changes, you can use the 
update drainage profile command. This will update all the profiles at once with the 
changed data.

Profile > Update Drainage Profile
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11.  Annotating Drainage Profiles

For this step, you still need to be in the dPCN#.dgn.  
In order to annotate the slope of the pipe properly you need to have the proper slope option on.

File> Project Options 
Units and Format Tab:

Slope:  50%

Evaluation > Profile > Annotate Drainage Profile
Load the preference storm.

Click <Apply> and then select each individual profile.  

Hint: Once all the annotation is done, you may need to clean up the profiles, because some of 
the annotation may be overlapping. 

Now that the drainage profile is drawn and annotated you can leave the d file.

12.  Storm Sewer on Cross Sections

Evaluation > Cross Section > Cross Sections
Under Update Cross Section: (To add storm sewer to existing cross sections)

Select Storm and Sanitary Leaf:
Select Cross Section Set you would like storm sewer displayed on.
Toggle on “Display On” and select the pipes you want displayed.
Check Redefine Bandwidth and set to 25’ for cross-sections cut every 
50’. Select projected pipe and inlets you want displayed.
Hit <Apply>

Note: If the projected pipes and inlets are greyed out, you may need to edit the Storm style to 
display projected line segments.
Tools > Style Manager

Scroll down to Storm: Click Edit
Select Surface Feature Folder

Under Cross Section Display, Toggle on “Projected Line 
Segments”
Hit <Apply> and close out of both windows.

13.  Generate reports

Tools > Drainage > Reports
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Appendix C - Miscellaneous Work Flows

 Creating DWG Files from ArcMap for Reference into Microstation 

Housekeeping Items:
Before you get started, follow these necessary steps: 

1) Open U:\tim\Temp\Connections and Copy all files
2) Paste items to C:\Users\trpr1(your #)\AppData\Roaming\ESRI\Desktop10.2\ArcCatalog
3) All Programs – ArcGIS – ArcCatalog 10.2 – Folder Connections – Connect to Folders C, M, & U

Install DataHound
Have you installed DataHound? If so, skip over this step. Otherwise, follow the steps below: 

1. Open ArcMap 10.2 – Create a new document – DO NOT execute the following steps using an 
existing mxd file.

2. Select “Blank Map” – click OK.   Wait for the document to open then - 

3. Go to the “Customize” menu and choose “Add-in Manager…”

4. In the Add-in Manager window, select the “Options” tab.

5. If your Add-In Manager already has the path highlighted in the previous step, you do not need to 
add it again. Skip Steps 6 through 10 and begin with Step 11 –  “Customize”

6. Press the “Add Folder…” button.
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7. At the bottom of the “Browse For Folder” window, in the text box where it shows your name, 
highlight the text and delete it.

8. Copy and paste the following path into that same text box:  
M:\All_SD\GIS\Extensions\Addins_General

9. Press the “OK” button.

10. Wait about 15 seconds until you see the path appear in the window (it should be in all uppercase 
letters).  If you don’t see the path appear after 30 seconds, then contact someone in GIS support.  
Tim Teaford (x6370), Chris Marsh (x6701), Sandra Panicucci (x5688)

11. Open the Customize window:

- At the bottom of the Add-In Manager window, press the “Customize…” button.

12. In the Customize window, select the “Commands” tab.
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13. Wait for the lists to populate.  In the Categories list on the left, select “_SD View Tools”.

14. In the Commands list on the right, find your tool(s) and drag them (FYI – you can only drag one 
tool at-a-time) out onto one of your main toolbars.

15. After you have successfully added the DataHound v10.0, REMOVE any other version of the 
Datahound you have added previously.  

16. To remove a tool from your project, select, hold your mouse button down and drag the tool from 
the ArcMap window into the Customize window and release the tool. It does not matter whether 
you are in the correct Category, because the Manager knows where the tool belongs. 

17. When you are finished, close the Customize window.

18. DO NOT SAVE this new file!

19. Close ArcMap and open your working document – if you have followed the instructions correctly 

the new Datahound will be in place and the old data hound v6.X will be gone.

Background Processing

This allows you to see the progress on executing export commands:  

Open ArcMap – GeoProcessing – Geoprocessing Options – Background Processing: Uncheck Enable

Creating DWG Files from ArcMap 

Open ArcMap 10.2 > Choose Blank Map (under My Templates) 

Add Information Layers to Map

Open DataHound v10.0 > Transportation/Networks > All Roads-DOT (Feature Classes) > Add Layers 
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Here are a few helpful layers (add as many as desired): 
 USGS Quad Map: DataHound > Imagery > DRG’s and Other Imagery> DRG’s 024K-

Statewide > Add Layers  
 Floodzones & Wetlands: DataHound > Water Resources > Floodzones-FEMA and Wetland 

Boundaries-NWI > Add Layers
 MRMs: DataHound > Transportation/Networks > Mileage Reference Markers > Add Layers

 Add Aerial Photo to Map
1. Add Basemap (as shown below) > Imagery > Add

 

 Add/Create Data from ArcCatalog 

 Culvert Inventory Data
1. Open ArcCatalog > Database Connections > Connect to Asset Management DB as user.sde > 

Click & Drag to Layers: HR50AssetManagement.dbo.vwCulvertInventory. 
2. New Query Layer > check ID > Finish
3. Under Layers, Right Click Culvert Inventory > Display XY Data > Edit > Geographic Coordinate 

System > North America > NAD 1983 > OK > OK
4. A new layer will be created with point symbols (this takes a few minutes, because it is an 

inventory of the whole state). 
5. Rename layer to “Culverts” or whatever you prefer. 
6. Delete/remove the table (this information is incorporated into the new point layer).   
7. For more information on the culverts: Right click > Open Attribute Table. (Values of -1 or 1 are 

True or  Yes; Values of 0 are False or No). 

 Accident Data
1. ArcCatalog > Database Connections > Connect to HR60 as ArcMap.odc > Drag to Layers under 

Table of Contents: dbo.Accident
2. Repeat Steps 3 thru 6 above.
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 Create DWG from Layers
1. Select area around your project: Select Features > Select by Rectangle. Draw a rectangle. You’ll 

notice layers are now highlighted. 

2. If the project is in State Plane North, skip step 3. 
3. Right click on Layers in Table of Contents > select Properties > Coordinate System tab > 

Projected Coordinate System > State Plane – NAD 1983 (US Feet) > NAD 1983 State Plane 
South Dakota S FIPS 4002 (US Feet) OK. 

4. Open ArcToolbox > Conversion Tools > To CAD > Export to CAD
Input Features: Choose Layers (You can choose more than one layer. The DWG will 
create these on individual levels)
Output Type: DWG_R2010
Output File: Navigate to your project file and save to “Other Agencies” folder.
Environments > Output Coordinates > 
For State Plane North: choose Output Coordinate System: “Same as Layer “Local Roads 
(NSTRI) - DOT””, OK > OK 
For State Plane South: choose Output Coordinate System: “Same as Display”

Arch sites and hydraulic pipe drainage areas can also be exported as DWG and referenced into 
Microstation.

 Reference DWG into Microstation
Attach reference DWG with Attachment Method: Coincident World

Hint: If the attachment does not line up with your project, run Bentley Config.
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Arch-Environmental Request 

Open the dPCN#.dgn and the rPCN#.dgn   Make sure you File/ Compress/ design   for each .dgn before 
converting to dwgs and then copy/place dwgs on the FTP server in the CoPCN# directory.

They are interested in the centerline alignment, stationing and work limits from the dfile and the new 
ROW, old ROW, and temporary easements from the rfile.

State in the email to the Environmental office what stage you are at with design for your project.  You may 
not have easements or still working on alignment, etc. just let them know.   Give the link to the FTP server 
from the internet with the User Name and Password.

 Export Shapefiles from MicroStation for Environmental
 
 If FSA Requests, refer to the link below.

U:\rd\Doc\WorkFlowDocs\Export DGN XFM to Shapefile.pdf

 Bluetop Report Workflow

Create or verify there is a project folder: U:\rd\prj\COUNPCN#\Staking\.  Save all of the Staking 
information in this folder.

Create Cross Sections:  EVALUATION>CROSS SECTION>CROSS SECTIONS
Make sure the correct Geometry is selected (Mainline)

- Create Cross Sections: Set the Preferences to the desired setting
General: Create: Window and Data

Interval: Set Interval (Normally to 50)
Surfaces: Select the Design Surface (Mainline) and PCNorg surfaces only

Include : Toggle ON “Crossing Features”
Toggle OFF “Components”

- Controls:
Limits: Toggle ON “Station”

Set Start and Stop Stations
Apply
Create Report:  EVALUATION>CROSS SECTION>CROSS SECTION REPORTS
- Main Tab:

Cross Section Set: Select target button and data on the cross section set you want to create your 
report from.
Surfaces: select Mainline
Toggle ON “Include Selected Features Only:”

Select: Centerline, L_Lane, L_Shoulder, L_Subgrade, R_Lane, R_Shoulder, R_Subgrade
- Slope Staking Tab:

Toggle ON > From Surface: > Select Mainline > Feature: Select Centerline
Apply

Option 1 Deliverable – Evaluation Folder > CrossSectionGradebook.xsl 
Option 2 Deliverable – Evaluation Folder > CrossSectionSurveyFormat.xsl

Save Report:  
Option 1 - File>SaveAs>U:\rd\prj\COUNPCN#\Staking\DTMNAME_Bluetop.doc
Option 2 - File>SaveAs>U:\rd\prj\COUNPCN#\Staking\DTMNAME_Bluetop.txt

file:///U:/rd/Doc/WorkFlowDocs/Export%20DGN%20XFM%20to%20Shapefile.pdf
file:///U:/rd/Doc/WorkFlowDocs/Export%20DGN%20XFM%20to%20Shapefile.pdf
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Staking Reports Workflow

The following work for construction staking shall be done in stakePCN.dgn

Drawing Hub Lines

There are 3 lines which must be drawn onto the plan view of the project to create the slope staking report.  
These are the left hub line, right hub line, and the centerline of the alignment.  The left and right hub lines 
can be drawn manually by using the smart line command in microstation.  The hub lines are the 
outermost limits of work (temporary easements or ROW for the project.)  Normally the temporary 
easements are located on level 13 of the “d” file, so turn off all other levels of this reference file.  The 
same goes for level 27 of the “r” file.  This will leave only the ROW line in the plan view.  Draw each of the 
hub lines by following the ROW and temporary easement lines from the beginning of the project to the 
end with one continuous linestring per side.  For sections of ROW in curves, snap to the ROW line at 
every station in order to get your hub line correct where reported at.

Note: The perimeter of the original ground surface should be drawn to check that the hub lines do not go 
outside of the original ground surface.  The hub lines should be moved in over the original ground surface 
in the immediate area where they fall outside.  If hub lines are not brought in, they will break the line 
segments where outside the original ground when draping. 

Tip: The easiest way to draw the left and right hub line is to create one long line string for each hub line 
with the smart line command from the beginning of the project to the end.  Then use the insert vertex 
command located in the Modify toolbar to insert as many points as you need along each hub line.

View Features

The centerline of the project must be drawn in plan view.  One method of viewing the centerline is to view 
the centerline features.  

From the InRoads menu bar, SURFACE>VIEW SURFACE>FEATURES.  
Surface: select Mainline.  This should display the list of features for the mainline surface.  
Features: select Centerline 
Apply - Places the centerline on the plan view. 
Close the dialog box.

Level 1 in the stakePCN.dgn file will have to be turned back on to see the centerline feature.

Drape Surface

These 3 line strings must now be draped to the existing surface. (PCNorg.dtm)
From the InRoads menu bar, SURFACE>DESIGN SURFACE>DRAPE SURFACE.  Be sure to 
have your “Locate Graphics” toggle ON, or you will not be able to select the graphics.  You need 
to make sure the “Locks” toolbar is shown on the top of your Inroads window. 
(TOOLS>CUSTOMIZE>LOCKS>CLOSE)
Destination Surface: select PCNorg 
Graphics>Input Mode: select Single  
Toggle ON “Destination Level:” select Level 9 
Toggle ON “Delete Original Graphics” 
Apply - select the 3 line strings created above (Centerline, Left Hub, & Right Hub)  Look at the 
status bar at the bottom of your screen to make sure you have successfully completed each line.  

Verify that you have deleted the original linestring.  
Check to see if you have draped the centerline and hub lines to the existing surface by turning off all of 
the levels except Level 9 and compare the elevations of the draped line to the existing surface.
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Import Surface

You will now import the centerline graphics.
From the InRoads menu bar, FILE>IMPORT>SURFACE  
From Graphics tab
Surface: select Mainline 
Load From: select Single Element 
Elevations: select Use Element Elevations   
Seed Name: type in CL_Exist 
Feature Style: select Centerline
Point Type: select Breakline
Toggle ON Exclude from Triangulation
Apply - data click on the centerline graphics.  InRoads prompt should read “Import Complete”

Repeat this process for the left and right hubs with the following exception; 
Seed Name: Type in Left_Hub, or Right_Hub (respectively) for both the left and right hub.
Triangulate the Mainline Subgrade surface 
From the InRoads menu bar, SURFACE>TRIANGULATE SURFACE
Surface: Mainline
Apply
FILE>SAVE>SURFACE – Saving the surface will save the centerline and hub line feature that 
you just made.

Create or Update Cross Sections

At this point, all of the necessary features have been imported into the design surface.  Now create cross 
sections in stakePCN.dgn from the beginning to the end of the project in 100 foot intervals showing the 
mainline surface and the original ground. (A guideline to create cross sections can be found in the CADD 
Procedures Manual.)  After the cross sections have been cut you need to check to make sure that the 
CL_Exist, Left_Hub, and Right_Hub features are at the original ground elevation. 

From the InRoads menu bar, EVALUATION>CROSS SECTION>CROSS SECTIONS
UPDATE CROSS SECTION>CROSSING FEATURES 
Cross Section Set: select the correct cross section set from the drop down menu or data on the 
“Target” button and data click on the correct cross section set
Toggle ON “Display On” 
Surface: select Mainline 
Feature: select CL_Exist, Left_Hub, and Right_Hub (you will need to hold in “Ctrl” on your 
keyboard to select all of the feature names at once)
Apply - review the cross section set to make sure a small white circle has been created at the 

existing ground elevation for the CL_Exist, Left_Hub, and Right_Hub feature.  (Make sure 
level 44 is ON to see feature circles.)

All of the features (white circles) that are shown on the cross sections will be available to be placed in a 
report.  Additional features should be added the same way that the hub lines features were.  All of the 
features on the mainline subgrade component (not the undercut component) should be shown with the 
exception of the exterior boundary and the features between the centerline and the edge of the roadway 
such as left lane, left shoulder, right lane and right shoulder, etc. (be sure to include centerline).  (Do not 
show the clearzone point unless there is a break to 3:1).   
If a staking contractor asks you for a finished surface staking report then you can display the finished 
component features on the cross sections and make an additional report.

Create Report:  EVALUATION>CROSS SECTION>CROSS SECTION REPORT
Main tab
Cross Section Set: select “Target” button and data click on the cross section set you want to 
create your report from.
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Include: Surfaces: Name: select Mainline
Toggle ON “Include Selected Features Only:”
Select: All Features that you want to be added into report
Apply

Save Report:  
Report 1:  Evaluation>CrossSectionAllFeatures.xsl
File>SaveAs>U:\rd\prj\COUNPCN#\Staking\DTMNAME_Features.doc

Report 2:  Evaluation>CrossSectionSlopeStakeListing.xsl
File>SaveAs>U:\rd\prj\COUNPCN#\Staking\DTMNAME_Slopestake.doc

If Northing and Easting is requested -
Report 3:  Evaluation>CrossSectionGradebookNE.xsl
File>SaveAs>U:\rd\prj\COUNPCN#\Staking\DTMNAME_FeaturesNE.doc

Staking XML & Machine Grading

The following is data that the Contractor may request from the designer for input into their grading 
equipment. The grading equipment is able to construct the grades directly from this data. The following is 
some of the typical information that has been requested. Only some of the following or possibly other data 
may be requested by individual Contractors based on their equipment needs. 

This data may also be requested for construction staking reports that are provided to the staking 
Subcontractor or SDDOT surveyors. When providing staking reports communicate with the Area Office to 
see which format the Subcontractor or SDDOT prefers.  Other construction staking reports may need to 
be provided to the surveyor in the form they request in addition to the XML reports.

Create or verify there is a project folder: U:\rd\prj\COUNPCN#\Staking\.  Save all of the Staking XML and 
Machine Grading information in this folder.
Load any microstation file of that project and InRoads software

Load project alignments and surfaces.

1.  XML Alignment Data:  Include all alignments required for construction.
InRoads: 
File > Translators > LandXML Translator… > Export Alignment Tab:
Geometry Project: ePCN# (or applicable)
Check each construction alignment and make the construction vertical alignment active if it is not 
already.
Include: Put cursor in box then select the “Filter” button.

Geometry Selection Filter toolbox: Select alignment under Available: and hit 
Add-> button to move under Selected:. OK.

Selected: Ensure all construction alignments are listed in the box.
Include Active Children Only:  Toggle on
Include All Cogo Points: Don’t toggle on (unless you have them for a special situation)
Linear Units:  Select - US Feet 
State: proposed
Save As… button or type in File Name: put file in project folder created above with the name 

“PCN#_AlignmentsALG.xml

Note: When supplying to the Contractor, state that the data is in “US Survey Feet”.
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2.  XML Surface Data:. Include all alignments required for construction.
InRoads: 
File > Translators > LandXML Translator… > Export Surface Tab:
Surfaces: select all construction subgrade surfaces 
Include Triangles: Toggle on
Include Features: Toggle on
Include Non Triangulated Features: Toggle on
Linear Units:  Select - US Feet 
State: proposed
Save As… button or type in File Name: put file in project folder created above with the name 

“PCN#_SubgradeDTM.xml”.

Repeat process by selecting all finished surfaces and name “PCN#_FinishDTM.xml”.
Repeat process by selecting original ground surface and name “PCN#_OriginalDTM.xml

Note: When supplying to the Contractor, state that the data is in “US Survey Feet”.

3.  XML Cross Section Data:  Do for all cross section sets for each alignment for the project.
InRoads: 
File > Translators > LandXML Translator… > Export Cross Sections Tab:

Note: If tab is not displayed, see instructions below to add.
Cross Section Set: select mainline (or applicable alignment set )
Linear Units:  Select - US Feet 
State: proposed
Save As… button or type in File Name: put file in project folder created above with the name 

“PCN#_MainlineCrossSection.xml, 
PCN#_XR106CrossSection.xml, etc” or others as below.

Add Export Cross Sections tab:
Tools > Application Addins… 

Select Variable Manager

Tools > Variable Manager…
Select LandXML Translator – Enable Cross Section under Command Behavior:

Note: This will translate everything in the InRoads Cross Section Set and only things in the 
InRoads Cross Section Set.

4.  AutoCAD File with Triangles (TIN): Include all alignments required for construction.
Create a new microstation file with the naming below. 
Draw triangles of construction alignment design surfaces if applicable:

InRoads > Surface > View Surface > Triangles > Surface: mainline and other alignments
Draw construction alignment features: Only do this if Contractor requests. 

InRoads > Surface > View Surface > Features:
Surface: mainline and other alignment surfaces
Features: select all 
Apply

Export to AutoCAD file (.dwg).
Microstation > File > Save As 
Save as type: Select: Autodesk(R) DWG Files (*.dwg)
Directories: Put in directory created above.
Files: Type in name per file naming below. (PCN#_Triangles.dwg)
Save > OK

Note: Subgrade and finished surfaces can be provided if triangles are drawn on separate levels.
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File Naming:
1. PCN#_AlignmentsALG.xml
2. PCN#_SubgradeDTM.xml
2. PCN#_FinishDTM.xml  (if you have one)
3. PCN#_MainlineCrossSection.xml
3. PCN#_XR106CrossSection.xml
4. PCN#_Triangles.dgn (& .dwg)

Contractor Data Requests:
Loren Fuhrmann, Diesel Machinery, requested 1 & 4 with features and all alignments in 
one TIN file with the mainline data on a separate level from the other alignments.
Derek Bunkers, Bowes Construction, requested 1, 2, & 4 with no features.

Designers: Please document additional contractor data requests above and let Warren know if other 
types of information is requested, so we can document.

Electronic File Guidance

Linework – A linework file is particularly useful to the contractors to use as reference markers in their 
machine control application. There may be different types of linework that is useful depending on the job 
being rural or urban. See Tip below for creating the file.

- Urban: This file should include plan alignments, stationing, roadway break lines, lane lines, 
exterior boundary, curb and gutter lines, sidewalk, entrances, side streets, temporary easements, 
drop inlets and pipe. The existing and proposed ROW linework should be included but trimmed to 
only show what is relevant for the project. It is noted to the contractor that the curb ramp linework 
is for information purposes only and that ADA requirements need to be verified in the field. At this 
time we should not show bridge objects (from bCN#.dgn), fence, lighting components, erosion 
control, pavement markings and joint layouts. These elements may be displayed in the future but 
not without further discussion.

o Common levels to be displayed:
 dPCN#.dgn: Levels (1, 2, 11, 12, 13, 16, 17, 28, 30, and 32)
 cgPCN#.dgn: Levels (16, 17, 19, 25, 26, 27, and 30)
 rPCN#.dgn: Levels (22, 23, 24, 25, 26, 27, 28 and 29) Existing ROW should be 

trimmed to show only what is needed along the corridor. Excess existing ROW 
should be deleted or clipped)

- Rural: This file should include plan alignments, stationing, ditch break lines, roadway break lines, 
lane lines, exterior boundary, culverts, approaches, ditch blocks and intersecting roads. The 
existing and proposed ROW linework should be included but trimmed to only show what is 
relevant for the project. At this time we should not show bridge objects (from bPCN#.dgn) file, 
fence, erosion control, and lighting components. These elements may be displayed in the future 
but not without further discussion.

o Common levels to be displayed:
 dPCN#.dgn: Levels (1, 2, 11, 12, 13, 16, 17, 28, 30, and 32)
 rPCN#.dgn: Levels (22, 23, 24, 25, 26, 27, 28 and 29) Existing ROW should be 

trimmed to show only what is needed along the corridor. Excess existing ROW 
should be deleted or clipped)

Tip: Create a new MicroStation file called PCN#_Linework.dgn and add other .dgn files as references. In 
the Level Display, turn on only the levels you want shown. A good starting place is the common levels 
outlined above. Once only those levels are turned on, from the references dialog box, select all of the 
references and select Tools > Merge Into Master. It will prompt you to select a view. Leave the “Allow 
Optimized Clipping” toggle off in the pop up. This will copy in only the levels that were turned on from the 
references into the PCN#_Linework.dgn file. Random lines assigned to those levels may exist outside of 
the design. A best practice would be to clean up those lines that aren’t needed.
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Generating A Sloped Surface

If you need to generate a surface that has a slope to it and or is not planer. One way to do it is to use the 
“Generate Sloped Surface Command”.

The following steps should be followed.
1. Draw your surface using Microstation.  Make sure all elements comprising the surface have the 

proper elevation. (az=___)  
2. If the surface is made up of several elements, use the “Create Complex Shape” command from 

Microstation to link all the individual elements into one.
3.    Create a new surface for your sloped surface. File> Surface >New
4.    Choose Surface > Design Surface > Generate Sloped Surface.

5.    Fill in the dialog box as shown above. Adjust the slopes, surface name and feature names as 
needed.

6.    Choose apply and follow the prompts on the screen.
7.    Triangulate the surface.  Surface >Triangulate Surface. (If you toggle on “Triangulate Surface” you 

won’t need to do this step.
8.    View triangles and contours to verify the surface is what you want.  

Note:  If your surface is not a perfect plane you will need to draw breaklines at the proper location and 
elevation using Microstation.  Then use the File>Import> Surface From Graphics command to import 
breaklines onto your surface and triangulate again.  
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General  Workflow for CM&P

The Construction Management and Payment (CM&P) system can be used to track your projects progress 
and construction changes.  The program will show on your desktop as a bulldozer icon.

Contact your supervisor to have the program added to your computer. 

To Find Your Project
Choose the Select icon for "Select A Contract" dialog window.  
Contract Status: default is Open but can be changed to All if project is not found under Open.
Search For: normally toggle PCN then type in number and click Search.
Click OK or double click project.
The window title bar will show Contract number and PCN (Project Control Number).

To Check Information on the Project
Choose the Contract icon for "Manage Contract" window.
This will give general information about the contract including the field Project Engineer under the 
Identifying tab.

To Check Construction Status of the Project
Choose the WPR (Work Progress Report) icon for "Bi-weekly Progress" window.
It defaults to the latest report with notes under the Comments tab.
Under the Contract Day Worked tab it shows the subcontractors and who was working.  

To Check Project Construction Changes 
By CCO Number 
Choose the CCO icon for "Contract Change Order" window.  Highlight a numbered Change Order 
to review.

For a summary of why changes were made, create a report:
Reports > CCO-220B

Exit when done.
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 Culvert Design Procedure 

Culverts and other highway drainage features should be designed using the SD Drainage Manual as 
located at Forms & Manuals - South Dakota Department of Transportation. Chapter, section and figure 
references provided below are from the SD Drainage Manual. The drainage manual has a general culvert 
design procedure located in Section 10.5.1. 

This document provides a simplified culvert design procedure that generally follows the requirements for 
using the culvert computer software HY-8 (Section 18.2.3 & Fig. 18.2-E). This document was created for 
use by the SDDOT Office of Road Design and does not replace the need to use the drainage manual. The 
manual, software and procedure follow the FHWA Manual HDS 5, Hydraulic Design of Highway Culverts. 
Two Examples are provided at the following locations: U:\rd\Misc\Office\Training\Culvert Design 
Training\culvert design example 1.docx & U:\rd\Misc\Office\Training\Culvert Design Training\culvert 
design example 2.docx

HY8 Start Up:
- HY8 software should be installed and run from the C: drive.
- HY8 tutorial is located at  C:\Program Files\HY-8 7.30\HY-8 7.3 QuickTutorial.pdf. (Use newer version 
if available.)
- Starting options: open an existing file or create a new project by add a culvert crossing.
- HY8 project file typical name and location: U:\rd\prj\PCN#\drainage\PCN#.hy8. 
- The HY8 file should typically contain all the pipes on the project.
- Under HY8 Project Explorer: Rename each crossing to the station. Additional wording can be added to 
the crossing name after the station if need to describe the analysis. The culvert name under the 
crossing can also be renamed.
- Double click on the crossing or the culvert to access and edit the crossing data.
- Exhibit 1 is the HY-8 main window and crossing data window. This shows the required input data 
including discharges, tailwater, roadway, culvert and culvert site data.
- File>Save As... to save data.  File>Save does not appear to save the data in the correct location if at 
all.

Assemble Site Data:  (Chapter 5). Typical site data required is as follows.
- Drainage letter from Bridge Hydraulics Office
- Drainage basin layout in ArcMap from Bridge Hydraulics Office
- Survey data
- Proposed roadway design

HY8 Input Data:  Discharge, Tailwater, Roadway, Culvert & Culvert Site

Discharge Data: (Chapter 7)
Discharge Method typically used is minimum, design and maximum. The other methods can be used 
as needed.
- Minimum flow is typically 0 cfs, but could be set to Q2, Q10 or other if need to review a lower 
frequency. 
- Design flow is the flow at the design frequency. Design Frequency is determined from Figure 7.6-A.
- Maximum flow is typically Q100 or the review frequency (Section 7.6.2.3).
Discharges are determined using the order of preferred methods as specified in Section 7.7.5. This 
order of discharge methods for Road Design is generally as follows for rural undeveloped drainage 
basins.

1. USGS 1998 Regression Equations (Section 7.9). Use for drainage areas within the applicable 
range from Figure 7.9-D. This figure shows that some of the hydrologic subregion equations are 
applicable for drainage areas under 200 acres. Also consider using this method for all drainage 
areas over 200 acres even when area is not within range from the figure. 

https://dot.sd.gov/doing-business/engineering/design-services/forms-manuals
https://dot.sd.gov/doing-business/engineering/design-services/forms-manuals
../../../Misc/Office/Training/Culvert Design Training/culvert design example 1.docx
../../../Misc/Office/Training/Culvert Design Training/culvert design example 1.docx
../../../Misc/Office/Training/Culvert Design Training/culvert design example 2.docx
../../../Misc/Office/Training/Culvert Design Training/culvert design example 2.docx
file:///C:/Program%20Files/HY-8%207.30/HY-8%207.3%20QuickTutorial.pdf
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2. Rational Method (Section 7.13). Use for drainage areas under 200 acres where above 
equations are not applicable. 

3. USGS 1980 Hydrograph with 1998 Discharges (Section 7.15). Very rarely used. Use when need 
to route flows by incorporating upstream storage volume (Sections 10.3.2.8 and 10.7). 

For drainage areas under 200 acres where regression equations are applicable it may be worth 
computing both methods to verify the regression equation results are reasonable.

Discharge computations are theoretical and not exact. This should be taken into account when 
designing culverts. The new culvert design should be compared with existing culvert size and 
conditions and what resulting changes to backwater and downstream flows will be.

USGS 1998 Regression Equation discharges can be computed using 
U:\apps\PROGRAMS\EXCEL\USGS1998.xls. The applicable hydrologic subregion and input parameters 
are typically obtained from the drainage letter.

Rational Method discharges can be computed using U:\apps\PROGRAMS\EXCEL\Rational Method 
Discharges.xlsx or the hydraulic toolbox software found at U:\apps\NCHRP\Hydraulic 
Toolbox\4.1\HydraulicToolbox.exe (Use newer version if available under this same directory). 
Rational method is Q=CiA. The drainage area is typically obtained from the drainage letter and the 
remaining input variables are determined by the culvert designer. Guidance for determining the input 
variables is found in Section 7.13 and also the above spreadsheet. See Exhibit 3A for additional runoff 
coefficients to those provided in Figure 7.13-A. 

- Drainage basin Time of Concentration (Tc) is computed to obtain the appropriate rainfall 
intensity (i) and can require considerable amount of judgment. The Tc is based on the time it 
takes water to flow from the most hydraulically remote point of the drainage basin to the culvert 
(longest time route). The types of flow drainage typically flows in begins as sheet flow, then 
shallow concentrated flow and finally channel flow to the culvert. The time for each type of flow 
should be computed.
- Length and slope of each of these types of flow should be determined from the survey where 
available, but most often must be estimated from the quad map. A good source for the quad 
map with drainage basin layouts is the ArcMap file provided by the Bridge Hydraulics Office. 
Measurements can be made directly in ArcMap. See Exhibit 2 for ArcMap view and notes on use. 
ArcMap files and quad maps can be referenced into microstation if desired by following other 
workflows concerning Wetlands from GIS and 7.5 Minute Quadrangles referenced into 
Microstation Files.
- Aerial photo from the ArcMap file, google map, or others can be used to estimate the flow type 
limits and runoff coefficients.
- Channel flow time in the drainage basin requires the channel velocity be computed. The velocity 
is computed by the manning’s equation for the surveyed or estimated channel section assuming 
bank-full condition. The channel velocity can be computed using the channel analysis tool in the 
hydraulic toolbox software referenced above. The hydraulic toolbox file and each analysis should 
be located and named similar to the HY8 file discussed above except with file ending in .hyd. 
Hydraulic Toolbox reference guide is located at U:\apps\NCHRP\Hydraulic Toolbox\4.1\Desktop 
Reference Guide.pdf  (Use newer version if available under this same directory).

Tailwater Data:  (Section 10.3.2.4)
- Model the actual tailwater water surface at the culvert outlet by the appropriate channel type 
available in HY8.
- Typically an irregular channel section is input using survey data and a typical cross section of the 
downstream channel near the culvert outlet. If a more typical channel section is taken farther 

../../../../apps/PROGRAMS/EXCEL/USGS1998.xls
../../../../apps/PROGRAMS/EXCEL/Rational Method Discharges.xlsx
../../../../apps/PROGRAMS/EXCEL/Rational Method Discharges.xlsx
../../../../apps/NCHRP/Hydraulic Toolbox/4.1/HydraulicToolbox.exe
../../../../apps/NCHRP/Hydraulic Toolbox/4.1/HydraulicToolbox.exe
../../../../apps/NCHRP/Hydraulic Toolbox/4.1/Desktop Reference Guide.pdf
../../../../apps/NCHRP/Hydraulic Toolbox/4.1/Desktop Reference Guide.pdf
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downstream, then the elevation of the section should be adjusted up as if the section was taken at 
the culvert outlet location based on the channel slope. The channel invert flowline elevation is 
typically similar to the culvert outlet elevation or the top of embedment depth where applicable, as 
discussed below.
- The slope of the tailwater channel should be obtained from the survey, but can be estimated from 
the quad map if survey is not available or sufficient. Quad map measurements can be taken from the 
ArcMap file.  
- Manning’s n values can be estimated from Exhibit 3B or Section 9.3.3.
- Tailwater elevations must correspond with the elevations for the roadway data and culvert site data. 

Roadway Data:  (Section 10.4.7)
- Model the actual overtopping section where culvert backwater will first begin to either flow over the 
roadway or to a different drainage basin. This overtopping section is the lower of the possibilities 
listed in Section 10.4.7, which may or may not be the same as the culvert allowable design 
headwater. The overtopping section should be modeled to elevations on both ends that are above 
the resulting maximum discharge headwater elevation, so an accurate maximum headwater is 
computed.
- Roadway Surface will be input as paved or gravel as appropriate. Use gravel for grassed locations 
assuming the grass will typically lay down as a more smooth surface.
- Top width will be the width of the item that is overtopping such as the top of finished surfacing on 
the highway or approach, 10’ for ditch blocks and 50’+/- for overtopping the summit of a ditch grade.
- Roadway elevations must correspond with the elevations for the tailwater and culvert site data.

Culvert Data:  (Section 10.3.3) 
- Shape and Material (Section 10.3.3.1)
- Diameter/Size (Section 10.3.3.3). Applicable culverts should meet minimum culvert width 
requirement in the Nationwide Permit as referenced in the following embedment depth discussions.
- Embedment Depth (Sections 10.3.4.6 & Appendix 10.A). This is the depth the culvert is countersunk 
below the channel flowline elevation for passage of aquatic organisms. The Bridge Hydraulics Office 
will provide these locations in the drainage letter. Embedment depth requirements are set by the US 
Army Corps of Engineers in the link “Nationwide Permit Regional Conditions for South Dakota” under 
http://www.nwo.usace.army.mil/Missions/RegulatoryProgram/SouthDakota.aspx. This depth is based 
on the culvert type, size and drainage area. Only one of the culverts of a multiple culvert installation 
may need to be countersunk depending whether the minimum culvert width requirement in the 
Nationwide Permit is met.
- Manning’s n (Figures 10.10-A). If embedment depth is specified then n values will be required for 
the pipe sides and for the natural bottom in the pipe.
- Culvert Type is typically set to straight. Broken-back type should be used when there is a change in 
slope along the length of the culvert, as done for downspouts (Sections 10.3.3.8, 10.3.3.9 & 10.9). 
The other inlet configurations are very rarely used (Section 10.8).
- Inlet Depression is very rarely used.
- Inlet Configuration should be set as follows (Section 10.3.3.11, Fig. 10.10-B & 10.10-C).

Sloped Ends – Mitered to Conform to Slope or Mitered – RCP, RCP Arch*, CMP & CMP Arch
Safety Ends – Mitered to Conform to Slope or Mitered – RCP, RCP Arch*, CMP & CMP Arch
Flared Ends – Square Edge with Headwall or Headwall - RCP, RCP Arch, CMP & CMP Arch 
Sectional Ends – Square Edge with Headwall - RCP & RCP Arch
No Ends on CMP – Thin Edge Projecting or Projecting - CMP & CMP Arch 

* HY8 does not provide a mitered edge treatment for RCP Arch, therefore change material to 
corrugated steel or aluminum and change the n value to 0.012. This follows footnote 2 in Figure 
10.10-C. Most likely the steel size will need to be defined from historic sizes with the one that 
matches the similar area of the desired RCP Arch. 

http://www.nwo.usace.army.mil/Missions/RegulatoryProgram/SouthDakota.aspx
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Culvert Site Data:  (Sections 10.3, 10.3.1.2, 10.3.3.4 thru 10.3.3.7) 
- Culvert Invert Data is typically the option to use to set the culvert elevation and length. 
- Inlet and outlet elevations are typically set to the actual culvert flowline elevations where the top of 
the pipe daylights and not at the end of the end sections. These elevations need to correspond with 
the tailwater and roadway elevations input above. If the culvert is countersunk by the embedment 
depth then the culvert inlet and outlet elevations need to be set that depth below the channel 
flowline. After the culvert is analyzed, the culvert cross section can be viewed to confirm the culvert 
is modeled correctly by selecting the culvert under the crossing in the HY-8 Project Explorer.
- Culvert length is specified by the inlet and outlet stations. Typically the inlet station is set to 0.0 ft 
and the outlet station is the culvert length. This length is from where the top of the pipe daylights. 
- Number of barrels will be set for each of the selected culverts (Section 10.3.3.4). Hit the “Add 
Culvert” button if the crossing requires multiple pipe with different sizes or properties. Examples 
might include adding a pipe next to an existing pipe or countersinking only one pipe of a multiple 
pipe crossing. After the culvert is analyzed, the front view at the inlet can be viewed to help show the 
differences of multiple pipe by selecting the crossing in the HY-8 Project Explorer.

Design Criteria: (Section 10.3)

Allowable Headwater: (Section 10.3.2.1)
- Determine which constraints and item establish the allowable design headwater as listed in section 
10.3.2.1.
- Document what item is controlling the allowable headwater along with it’s elevation and the 
resulting allowable headwater depth from the proposed culvert inlet flowline elevation.
- Intersecting road and approach culverts should be designed to meet the requirements of the 
adjacent mainline highway at the highway’s design storm frequency in addition to meeting the 
intersecting road and approach requirements (Figure 7.6-A).

Outlet Protection: (Sections 10.3.2.6, 10.3.4.2 and 10.4.6)
- Provide culvert outlet protection based on culvert outlet velocity and guidance in Section 10.4.6.

HY8 Analysis and Results:
- After the above HY8 input data has been entered, hit the Analyze Crossing button. A Summary of 
Flows at Crossing window will open with Display options available to toggle.
- Crossing Summary Table display provides the overtopping discharge and flows through the culvert 
and over the roadway with the resulting headwater elevations. Example of this exported report is 
Exhibit 4A. 
- Culvert Summary Table display provides a full summary of the culvert’s flow, headwater, tailwater and 
velocity. Example of this exported report is Exhibit 4B.
- Review either or both of the above two summary table displays and then adjust the culvert size as 
needed until the allowable headwater design criteria is met. Return to the input data by hitting the Edit 
Input Data.. button. Compare proposed culvert size with the existing culvert size and verify if the size is 
reasonable.
- When the culvert size is obtained, export both of the above 2 summary table displays for each 
culvert. Name the Crossing Summary Table to “STATIONovertopping.pdf” and name the Culvert 
Summary Table to “STATIONresults.pdf” and place under U:\rd\prj\PCN#\drainage\.

Crossing Summary Table: (Exhibit 3) 
The overtopping flow and elevation from this table will be used and documented according to Section 
10.4.7 for final use on the plan/profile sheets. The overtopping year will be determined according to 
Section 10.4.7.

Culvert Summary Table: (Exhibit 4) 
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- Ensure the headwater elevation at the design discharge is at or below the allowable headwater 
elevation.
- Results show both inlet control and outlet control headwater depths. The highest depth between 
these two is used to determine the headwater elevation and indicates the type of control the culvert 
is in (Sections 10.4.3 thru 10.4.6 and 10.4.8).
- Culvert outlet velocity at the design discharge is used to determine the need for outlet protection as 
discussed above. The culvert outlet depth, tailwater depth and tailwater velocity results can also be 
used for consideration in the determination for outlet protection.

Documentation:
- Culvert Design Form for each culvert. Use to document HY8 input data, design criteria, methods used, 
recommendations and reasons for the design decisions (Section 6.5.2). Example forms are Figure 
10.10-T or Exhibit 5. An electronic file of this form should be saved under U:\rd\prj\PCN#\drainage\.
- HY8 output results documented for each culvert as discussed above and examples in Exhibits 4A & 
4B.
- Overtopping results should be summarized and documented according to Section 10.4.7.
- Special reports and recommendations may be written and provided to other offices as needed, such 
as culvert lining projects.

Thrust Blocks for Downspouts: (Section 10.3.3.9)
- Broken-back culverts/downspouts that require thrust blocks on the elbows/bends should be 
determined by the guidance at U:\rd\Doc\WorkFlowDocs\Thrust Block Analysis for Downspout.docx.

Exhibit 1 - HY-8 Software Main Window & Crossing Data Window

file://state.sd.local/work/TRPR1/rd/Doc/WorkFlowDocs/Thrust%20Block%20Analysis%20for%20Downspout.docx
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Exhibit 2 – ArcMap view with drainage basins layer shown as provided by the Bridge Hydraulics office

To show the drainage basins in ArcMap the following may need to be done. Toggle on the drainage 
basins layer. A Set Data Source window will open. Select drainage basins and hit Add.

Use the measure tool   to measure distances in ArcMap. Ensure the measurements are in the correct 
units.

Ensure the ArcMap file is set to the correct coordinate system by measuring the distance of a section line. 
Have Bridge Hydraulics Office correct the file if it does not measure correctly.
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Exhibit 3A – Runoff Coeffients (C) for the Rational Equation.
These are in addition to those found in Figure 7.13-A of the SD Drainage Manual.
(Source: NDDOT Urban Storm Drainage)

Type of drainage area Runoff Coefficients (C)
Roadway Ditches …………………………………………. 0.20 – 0.50
Forested Areas ……………………………………………. 0.10 – 0.30
Meadows ………………………………………………….... 0.10 – 0.40
Pasture Land …………………………………………...... 0.20 – 0.45
Cultivated Land, Sand and Gravel:

Flat (<2%) ……………………………………… 0.20 – 0.30
Average (2-7%) ………………………………. 0.30 – 0.35
Steep (>7%) …………………………………… 0.35 – 0.45

Cultivated Land, Clay and Loam:
Flat (<2%) ……………………………………… 0.30 – 0.45
Average (2-7%) ………………………………. 0.45 – 0.55
Steep (>7%) …………………………………… 0.55 – 0.70

Note: For the above ranges of values, use the lower values for flat slopes, permeable soils and dense 
vegetation and use the higher values for steep slopes, impermeable soils and sparse vegetation.

Exhibit 3B – Manning’s n-values for Small Natural Stream Channels. 
Surface width at flood stage less than 100 ft. 
(Source: FHWA Manual HDS 5, Hydraulic Design of Highway Culverts)

n-values
1. Fairly regular section:
a. Some grass and weeds, little or no brush ……………………………………………………………… 0.030 - 0.035
b. Dense growth of weeds, depth of flow materially greater than weed height …………….. 0.035 - 0.05
c. Some weeds, light brush on banks …………………………………………………………….…………. 0.035 - 0.05
d. Some weeds, heavy brush on banks …………………………………………………………….………. 0.05 - 0.07
e. Some weeds, dense willows on banks …….……………………………………………………………. 0.06 - 0.08
f. For trees within channel, with branches submerged at high stage, 
increase all above values by ………………………………………………………………………….………… 0.01 - 0.02

2. Irregular sections, with pools, slight channel meander; 
increase values given above about ………………………………………………………………..…………. 0.01 - 0.02

3. Mountain streams, no vegetation in channel, banks usually steep,
trees and brush along banks submerged aat high stage:
a. Bottom of gravel, cobbles, and few boulders …………………………………………………………. 0.04 - 0.05
b. Bottom of cobbles, with large boulders …………………………………………………………………. 0.05 - 0.07
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Exhibit 4A – HY8 Crossing Summary Table Report used for the overtopping flow information

Exhibit 4B – HY8 Culvert Summary Table Report
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Exhibit 5 – Culvert Design Form Example
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 PathWeb Workflow

PathWeb Link: https://pathwebdev.sd.gov/Pathweb

FINDING LOCATION #1: Using the “Find Road Section Locator”.

1. Click the drop-down box by “Cycle”
2. Choose the year of collection that you want.
3. Click “Find Road Section” 
4. A box will appear. Select the highway you want. Highways with only two digits in them will have a 

“0” as the first number. For example, Highway 90 will be 090.
5. Select your distance. You will have a choice between increasing and degreasing. If you’re 

travelling east and north, you will be going in the increasing direction. If you’re travelling west and 
south, you will be going in the decreasing direction.

6. Selection Route ID.
7. You can also select the specific MRM for your location.

FINDING LOCATION #2: Using the Map

1. Click the drop-down box by “Cycle”
2. Choose the year of collection that you want.
3. Click and drag the map in order to move it.
4. Zoom in and out of the map by using the wheel on you mouse. If you don’t have a mouse wheel, 

use the “+” and “-“ keys on the map.
5. Click the desired location on the purple line. (CLICK THE PURPLE LINE AND WAIT 7 SECONDS! 

BE PATIENT!)
                                     

BASIC OPERATION AND DISPLAYING INFORMATION

1. Click the drop-down box by “Cycle”
2. Click the three bars to the left of “Cycle”.
3. Click “Windows”

This will show all cameras and display options
4. Click “Forward View. This will show the front image. 
5. Click “Forward View Settings” and check all of the boxes.
6. Click “Pavement View” for pavement images.
7. Click “Rear View” for the image on the right side of van.

 *Note: You can move and adjust the images by clicking and dragging.
8. In order to change the speed, check the box next to “Playback Settings”. You will be presented 

with a box with a bar in it. If you want to decrease your speed, click the arrow on the left-hand 
side of the box. If you want to increase your speed, click the arrow on the right-hand side of the 
box. 

https://pathwebdev.sd.gov/Pathweb
https://pathwebdev.sd.gov/Pathweb
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 7.5 Minute Quadrangles referenced into MicroStation Files.

Need to know:
 The Latitude/Longitude of the project.
 State Plane Coordinate(SPC) Zone for the project. 

o The Zone for each county is listed in the CADD Procedures Manual,
 Section A – General, page A8 .

Open your DGN.
Set the Geographic Coordinate System  

Tools > Geographic > Select Geographics Coordinate System 
Geographic Coordinate System > From Library (SD83-NF or SD83-SF)

Attach as a reference the DGN with the Quadrangles attached. Using the 
             Attachment Method:  Geographic - Reprojected

 Location U:\rd\Misc\Maps\Quadrangles\
 File Name will match LAT/LONG. 

Note: Recommend Clipping this reference file. 

Other information to reference into your DGN
 MRM     U:\rd\Misc\GIS\ShapeFiles\MRM\MRM.shp
 Wetlands, Hydraulic Drainage Areas and Archeological sites found project specific

http://www.sddot.com/business/design/docs/cadd/CADD-General.pdf
http://www.sddot.com/business/design/docs/cadd/CADD-General.pdf
../../../Misc/Maps/Quadrangles/
../../../Misc/GIS/ShapeFiles/MRM/MRM.shp
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 Creating Alternate Surface

To create a dtm surface of the proposed finish surface along with the subgrade surface that is normally 
created, an alternate surface may be created. This may be helpful in annotating the centerline point of 
the finished surface using the 10_20 or 20_40 scale preferences rather than just the centerline point of 
the subgrade surface. Another useful aspect of the alternate surface is that the designer can display 
either contours or triangles of the finished surface to use for urban grading. It is a quick and easy way to 
see what the actual finished elevations will be without having to add the surfacing thickness to the 
subgrade.

To create an alternate surface:
 Select Modeler <Create Template or Inside the Roadway Designer, Select the “Open Template 

Library” Button 
 Once inside the template library for your project, double click on a template that is going to be 

used on the project.
 Select a point to edit along the finished surface component that you would like to include in the 

new alternate surface.  A good point to start with for editing would be the left outside lane 
point. Double click the point or Right Click < Edit Point…

 Next to Alternate Surface: Type in the name of the alternate surface that you would like to call 
it. For this example you would name it Finish as shown below. Also, you will want to give it a 
Surface Feature Style: The “Finish” style is a good one to use.
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 Once you have typed in the name of the surface, click <<Apply>>. Repeat this process for the 
other points you wish to include in the alternate surface by using the drop down and selecting 
the surface name that you entered for your first point.

 Repeat this process for the other templates used for the project making sure to use the same 
alternate surface name.

 Save template library.
 Make sure to go to Corridor < Template Drops… and synchronize your Template Library changes 

that you just made.

 Select Corridor < Create Surface… or select the “Create Surfaces” Button 
 In the Create Surface dialog box turn on the “Create Alternate Surfaces” check box. Select 

<<Apply>>.
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 Your new surface will be created.  By default the regular surface created will be the same as the 
Corridor name which is Mainline in this case. The alternate surface will be named Mainline – 
Finish in this case or whatever you had named your alternate surface.

 Save the newly created surface for future use.
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